Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

VPN con tablet Android

 
Nuovo argomento   Rispondi    Indice del forum -> VPN
Precedente :: Successivo  
Autore Messaggio
mazinga



Registrato: 16/07/09 17:04
Messaggi: 7

MessaggioInviato: Lun Mag 28, 2012 11:21 am    Oggetto: VPN con tablet Android Rispondi citando

Ciao a tutti,

ho preso da poco un tablet android 3.2(Vodafone tab della ZTE), ho già configurato due connessioni VPN con ZS sia LAN to LAN (con 4 sedi) e road-warrior (Con certificato senza PWD)

Ora stavo provando a configurare la VPN anche sul tab ma senza successo, avete qualche feedback in merito?
Top
Profilo Invia messaggio privato
NdK



Registrato: 27/01/10 12:36
Messaggi: 466

MessaggioInviato: Mar Mag 29, 2012 9:36 am    Oggetto: Rispondi citando

Sto cercando pure io di configurarla, ma Android 4 pare prevda solo autenticazione PSK e con certificato... Sad
Top
Profilo Invia messaggio privato
mazinga



Registrato: 16/07/09 17:04
Messaggi: 7

MessaggioInviato: Mar Mag 29, 2012 12:03 pm    Oggetto: Rispondi citando

Ciao NdK,

sono riuscito a configurare la VPN L2TP Cert con il tool built-in di android (io ho Honeycomb 3.2), purtroppo io ho nel server principale la beta 13 quindi posso fare l'autenticazione solo con l'user admin (c'è un bug e quelli creati dopo non si autenticano su Kerberos).

In pratica riesco ad accedere alla mia rete privata ma non più a navigare in internet Sad ho provato con il nat-T ma non è ancora attivo nella beta 13.

Il ping funziona quindi è solo un problema di dns, ho inoltre provato ad inserire il dns interno nella config di android ma non va, nemmeno mettendone uno pubblico (fastweb, alice, ecc...)


Qualche suggerimento?
Top
Profilo Invia messaggio privato
ChristianFilippi



Registrato: 10/08/11 14:57
Messaggi: 2

MessaggioInviato: Ven Ago 31, 2012 7:48 am    Oggetto: Rispondi citando

Io ho rootato il telefono e installato busybox e openvpn (installer e setup)
e funziona.
^^
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1505

MessaggioInviato: Ven Ago 31, 2012 9:10 pm    Oggetto: Rispondi citando

La 2.0.RC1 supporta le VPN PPTP che e' di immediata configurazione sia su Android che su iPhone e iPad.

Saluti
Fulvio
Top
Profilo Invia messaggio privato
Hook



Registrato: 06/06/08 14:56
Messaggi: 37

MessaggioInviato: Dom Gen 13, 2013 11:32 am    Oggetto: Rispondi citando

Ho anch'io il problema di connettere android (Galaxy SIII) con ZS.
OpenVPN (che uso per i PC) non riesco a configurarlo (su Android, ovvio)

[quote="fulvio"]La 2.0.RC1 supporta le VPN PPTP che e' di immediata configurazione sia su Android che su iPhone e iPad.
Saluti
Fulvio[/quote]

Ok, è vero, ma :
1) La VPN PPTP su Android deve essere riavviata manualmente tutte le volte che si disconnette,
non solo se esco e passo da wifi a 3G ma ad ogni cambio cella o se passo da un garage dove non c'è segnale 3G.
[b]Quindi non è mai connessa.[/b]
2) A brevissimo reinstallerò la beta 16 perché la 2.0 ha ancora troppi bug sugli accessi esterni.

Qualcuno è mai riuscito a configurare OpenVPN su Android?
Top
Profilo Invia messaggio privato
Arioch



Registrato: 22/07/08 14:33
Messaggi: 37

MessaggioInviato: Gio Gen 31, 2013 2:25 pm    Oggetto: Rispondi citando

Ciao

Io sono riuscito sia un Samsung S3 che su un Samsung tablet 7", utilizzando Openvpn for android reperibile in play store, a collegarmi e ricevere l'indirizzo ip dal mio ZS, però a questo punto non riesco a vedere gli ip interni della LAN di zs e dalla lan non vedo il dispositivo android.
La differenza che ho notato è che di default la vpn di zs crea un device di tipo tap, mentre questa app funziona solo se creato un device tun, a questo punto però ho un warning nel log he segnala un parametro scorretto dato da ifconfig.
Di seguito il log che genera, ho segnalato in rosso il warning:

In esecuzione su GT-P6200 (smdk4210) samsung, Android API 15
Log cleared.
Configurazione in corso...
P:MANAGEMENT: CMD 'signal INT'
P:Closing TUN/TAP interface
P:SIGINT[hard,] received, process exiting
P:MANAGEMENT: >STATE:1359637049,EXITING,SIGINT,,
started Socket Thread
Stato della rete: CONNECTED to WIFI
P:Initializing Google Breakpad!
P:OpenVPN 2.3_rc1+dspatch3 android-14-armeabi-v7a [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Dec 25 2012
P:MANAGEMENT: Connected to management server at /data/data/de.blinkt.openvpn/cache/mgmtsocket
P:MANAGEMENT: CMD 'hold release'
P:MANAGEMENT: CMD 'bytecount 2'
P:MANAGEMENT: CMD 'state on'
P:MANAGEMENT: CMD 'proxy NONE'
P:WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
P:Socket Buffers: R=[131072->131072] S=[16384->131072]
P:Protecting socket fd 4
P:MANAGEMENT: CMD 'needok 'PROTECTFD' ok'
P:Attempting to establish TCP connection with [AF_INET]192.168.50.2:20100 [nonblock]
P:MANAGEMENT: >STATE:1359637053,TCP_CONNECT,,,
P:TCP connection established with [AF_INET]192.168.50.2:20100
P:TCPv4_CLIENT link local: (not bound)
P:TCPv4_CLIENT link remote: [AF_INET]192.168.50.2:20100
P:MANAGEMENT: >STATE:1359637054,WAIT,,,
P:MANAGEMENT: >STATE:1359637054,AUTH,,,
P:TLS: Initial packet from [AF_INET]192.168.50.2:20100, sid=7a353f97 043495d4
P:VERIFY OK: depth=1, O=sogeco, OU=zslu a9cb, CN=ZeroShell
P:VERIFY OK: depth=0, OU=Hosts, CN=zslu.sogeco.local
P:WARNING: 'dev-type' is used inconsistently, local='dev-type tun', remote='dev-type tap'
P:WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1544', remote='link-mtu 1576'
P:WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1532'
P:Data Channel Encrypt: Cipher 'BF-CBC' initialized with 128 bit key
P:Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
P:Data Channel Decrypt: Cipher 'BF-CBC' initialized with 128 bit key
P:Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
P:Control Channel: TLSv1, cipher TLSv1/SSLv3 DHE-RSA-AES256-SHA, 2048 bit RSA
P:[zslu.sogeco.local] Peer Connection Initiated with [AF_INET]192.168.50.2:20100
P:MANAGEMENT: >STATE:1359637056,GET_CONFIG,,,
P:SENT CONTROL [zslu.sogeco.local]: 'PUSH_REQUEST' (status=1)
P:PUSH: Received control message: 'PUSH_REPLY,route-gateway 192.168.248.254,,dhcp-option DNS 192.168.248.254,route remote_host 255.255.255.255 net_gateway 1,route 192.168.0.0 255.255.0.0,ping 5,ping-restart 60,ifconfig 192.168.248.100 255.255.255.0'
P:OPTIONS IMPORT: timers and/or timeouts modified
P:OPTIONS IMPORT: --ifconfig/up options modified
P:OPTIONS IMPORT: route options modified
P:OPTIONS IMPORT: route-related options modified
P:OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
P:WARNING: Since you are using --dev tun with a point-to-point topology, the second argument to --ifconfig must be an IP address. You are using something (255.255.255.0) that looks more like a netmask. (silence this warning with --ifconfig-nowarn)P:ROUTE_GATEWAY 192.168.50.1/255.255.255.0 IFACE=wlan0 HWADDR=84:25:db:ff:e9:ba
P:do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
P:MANAGEMENT: >STATE:1359637057,ASSIGN_IP,,192.168.248.100,
P:MANAGEMENT: CMD 'needok 'IFCONFIG' ok'
P:MANAGEMENT: >STATE:1359637057,ADD_ROUTES,,,
P:MANAGEMENT: CMD 'needok 'ROUTE' ok'
P:MANAGEMENT: CMD 'needok 'ROUTE' ok'
P:MANAGEMENT: CMD 'needok 'ROUTE' ok'
P:MANAGEMENT: CMD 'needok 'DNSSERVER' ok'
P:MANAGEMENT: CMD 'needok 'OPENTUN' ok'
P:Initialization Sequence Completed
P:MANAGEMENT: >STATE:1359637057,CONNECTED,SUCCESS,192.168.248.100,192.168.50.2

Se qualcuno ha qualche idea, io lato config android le ho provate tutte ma non funziona.
Top
Profilo Invia messaggio privato
redfive



Registrato: 26/06/09 22:21
Messaggi: 365

MessaggioInviato: Gio Gen 31, 2013 6:46 pm    Oggetto: Rispondi citando

Forse ti può essere utile ciò che ha suggerito Fulvio nel 2009
Citazione:
To make Zeroshell use tun devices instead of tap ones you should:

cd /root/kerbynet.cgi/scripts
grep -w tap *

and for any lines the contains the word tap to change it with tun.

To make permanent the changes, copy the modified files in the directory /Database and then create a pre-boot script (Setup->Startup/Cron) which copies them in /root/kerbynet.cgi/scripts

Regards
Fulvio
qui , http://www.zeroshell.org/forum/viewtopic.php?p=4805#4805 , e http://www.zeroshell.org/forum/viewtopic.php?t=3910&sid=d45e8047eedb9355c02b4ebfa025b27e
ciao
Top
Profilo Invia messaggio privato
Francesco Steno



Registrato: 26/03/10 14:59
Messaggi: 181

MessaggioInviato: Mar Feb 05, 2013 11:22 am    Oggetto: Rispondi citando

mazinga ha scritto:

In pratica riesco ad accedere alla mia rete privata ma non più a navigare in internet Sad ho provato con il nat-T ma non è ancora attivo nella beta 13.

Il ping funziona quindi è solo un problema di dns, ho inoltre provato ad inserire il dns interno nella config di android ma non va, nemmeno mettendone uno pubblico (fastweb, alice, ecc...)


Qualche suggerimento?


non credo sia un problema di DNS, ma di routing.
Nel tuo file di configurazione devi settare la rete alla quale di connetti es.

Codice:
route 192.168.101.0 255.255.255.0 192.168.233.1


Se ti va posta il tuo file di configurazione, e una descrizione delle reti ...
Top
Profilo Invia messaggio privato Invia e-mail
mamojdick



Registrato: 07/12/12 19:24
Messaggi: 4

MessaggioInviato: Lun Mag 13, 2013 12:01 pm    Oggetto: Rispondi citando

Salve,
ma alla fine qualcuno è riuscito a far funzionare gli Android con OpenVPN?
Ho provato a cambiare le interfacce in "tun" con la 2.0RC2, ma non mi vanno neanche i cliente windows. Più precisamente chiudono la connessione ma poi non transita neanche un pacchetto (con regole firewall disabilitate=tutto aperto).
Qualcuno ha esperienza?
Grazie
Top
Profilo Invia messaggio privato
Hook



Registrato: 06/06/08 14:56
Messaggi: 37

MessaggioInviato: Lun Mag 13, 2013 12:44 pm    Oggetto: Rispondi citando

Io ci ho rinunciato.

OpenVPN -N O N- funziona con Android, anche se ci sono le app.
E non importa che siano free o a pagamento, semplicemente non vanno !!!

Attualmente uso L2TP/IPSEC, con tutti i problemi che comporta,
ma, riavviandola manualmente ogni volta che mi sposto di qualche metro,
si riesce a lavorare.

Una cosa è la teoria, ma quando vuoi scendere in pratica......

Ciao ed auguri
Carlo
Top
Profilo Invia messaggio privato
mamojdick



Registrato: 07/12/12 19:24
Messaggi: 4

MessaggioInviato: Gio Giu 06, 2013 3:53 pm    Oggetto: Rispondi citando

Scusa l'insistenza...
ma non riesco a far connettere un tablet android con L2TP/IPSEC.
Tutto funziona se sono sulla stessa rete (No NAT), ma se il tablet è dietro un'altra adsl non si connette. Sono io che sbaglio qualcosa o realmente la versione 2.0 RC2 non supporta il NAT-T (che ovviamente ho selezionato).
Voi che release avete usato per farlo funzionare?
Grazie anticipatamente.
Top
Profilo Invia messaggio privato
Xaro



Registrato: 23/07/12 10:10
Messaggi: 39

MessaggioInviato: Ven Set 06, 2013 10:40 am    Oggetto: Rispondi citando

anch'io aspetto una risposta, ho lo stesso problema... non mi si connettono tutti i dispositivi android
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> VPN Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it