Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Help Radius authentication su AD w2k8 per accesso WIFI

 
Nuovo argomento   Rispondi    Indice del forum -> RADIUS 802.1x e Captive Portal
Precedente :: Successivo  
Autore Messaggio
simonc



Registrato: 04/04/12 16:40
Messaggi: 3

MessaggioInviato: Mer Apr 04, 2012 4:58 pm    Oggetto: Help Radius authentication su AD w2k8 per accesso WIFI Rispondi citando

Buongiorno a tutti,

Ho provato a cercare ma non sono riuscito a trovare una soluzione sul forum alla mia esatta problematica e spero possiate darmi un aiuto.

L'idea di base sarebbe che ZS fungesse da server di accesso per la mia rete Wifi autenticando solo gli utenti nel mio dominio Active Directory su Windows Server 2008 R2.

Fondamentalmente non riesco a far comunicare ZS verso il 2008 via Radius.
Se riuscissi a sincronizzare l'active directory con ZS sarebbe la cosa migliore cosi delegherei la gestione Radius solo a quest'ultimo, ho visto che c'è una funzione di sincronizzazione ma è disabilitata in questa versione beta.

Ho provato a far comunicare il Radius server ZS con il Radius Windows server 2008 attivandoli tutti e due e configurando ZS che punti al domain controller come proxy radius ( accounting = yes) ma continuo ad avere errori, di sicuro mi manca qualcosa nella configurazione .

17:50:35 TLS Alert read:fatal:unknown CA
17:50:35 TLS_accept: failed in SSLv3 read client certificate A
17:50:35 rlm_eap: SSL error error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
17:50:35 SSL: SSL_read failed inside of TLS (-1), TLS session fails.
17:50:35 Login incorrect ( [ldap] User not found): [wifitest] (from client test port 0 cli 00-xx-xx-xx-xx-xx)
17:50:38 Login incorrect ( [ldap] User not found): [CED] (from client test port 0 cli 00-27-10-5A-C4-D4)
17:50:55 Login incorrect (Home Server says so): [wifitest@lamma.it] (from client test port 0 cli 00-xx-xx-xx-xx-xx)
17:50:58 Login incorrect ( [ldap] User not found): [CED] (from client test port 0 cli 00-27-10-5A-C4-D4)

Ho guardato nelle varie guide ma non sono riuscito a trovare una soluzione, mi manca il knowhow della parte kerberos e certificati sicuramente, probabilmentesbaglio proprio lì !?

simone
Top
Profilo Invia messaggio privato
simonc



Registrato: 04/04/12 16:40
Messaggi: 3

MessaggioInviato: Mar Apr 10, 2012 12:07 pm    Oggetto: Rispondi citando

Nessun aiuto.
A letto le guide per la configurazione di W2k8 ma non funzionano.

Il captive portal configurato con la risoluzione automatica del KDC con il DNS funziona, ma non è il mio scopo principale.
Io vorrei semplicemente far autenticare attraverso il mio access point in radius verso zeroshell i miei utenti di dominio AD.

Con i dispositivi mobili apple iphone e ipad arrivo all'accettazione del certificato zeroshell.example.com poi mi da errore , con dei portatili mi da errore subito dopo aver inserito le credenziali , senza farmi accettare certificati ne niente.

idee?

Visto che il CP mi funziona e l'autenticazione diretta no, deduco che "il giro" di autenticazione verso il mio server W2k8 sia diverso?
Top
Profilo Invia messaggio privato
simonc



Registrato: 04/04/12 16:40
Messaggi: 3

MessaggioInviato: Mar Apr 10, 2012 4:29 pm    Oggetto: Rispondi citando

Rieccomi,

mi correggo , mi funziona il CP ma solo se mi autentico per test quando sono già in rete locale, perè il login con l'utente di dominio mi va a buon fine.
Mentre se provo con un portatile con Win7 ad entrare nella Wifi collegata in Radius allo ZS mi chiede l'autenticazione ci pensa ma dopo qualche secondo va in errore e mi dice impossibile connettersi.
Nel ZS i logs sono quelli che ho postato prima, mentre da ipad per esempio mi viene presentato correttamente il certificato Zeroshell accetto e poi mi va in errore(invece se creo un user Zeroshell locale mi entra e funziona).
Perchè il portatile mi chiede immediatamente la password e l'user senza redirezionarmi al Captive portal?

Direi che è proprio la comunicazione tra ZS e il server Active directory che ha problemi, nonostante il captive portal che di per se invece per l'autenticazione e basta, funziona.
Top
Profilo Invia messaggio privato
salemt



Registrato: 12/05/12 02:21
Messaggi: 15

MessaggioInviato: Sab Mag 26, 2012 1:22 am    Oggetto: Rispondi citando

ciao
hai poi risolto?
Top
Profilo Invia messaggio privato
macsheva



Registrato: 28/08/12 15:58
Messaggi: 2

MessaggioInviato: Sab Set 01, 2012 3:19 pm    Oggetto: Re: Help Radius authentication su AD w2k8 per accesso WIFI Rispondi citando

simonc ha scritto:
Buongiorno a tutti,

Ho provato a cercare ma non sono riuscito a trovare una soluzione sul forum alla mia esatta problematica e spero possiate darmi un aiuto.

L'idea di base sarebbe che ZS fungesse da server di accesso per la mia rete Wifi autenticando solo gli utenti nel mio dominio Active Directory su Windows Server 2008 R2.

Fondamentalmente non riesco a far comunicare ZS verso il 2008 via Radius.
Se riuscissi a sincronizzare l'active directory con ZS sarebbe la cosa migliore cosi delegherei la gestione Radius solo a quest'ultimo, ho visto che c'è una funzione di sincronizzazione ma è disabilitata in questa versione beta.

Ho provato a far comunicare il Radius server ZS con il Radius Windows server 2008 attivandoli tutti e due e configurando ZS che punti al domain controller come proxy radius ( accounting = yes) ma continuo ad avere errori, di sicuro mi manca qualcosa nella configurazione .

17:50:35 TLS Alert read:fatal:unknown CA
17:50:35 TLS_accept: failed in SSLv3 read client certificate A
17:50:35 rlm_eap: SSL error error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
17:50:35 SSL: SSL_read failed inside of TLS (-1), TLS session fails.
17:50:35 Login incorrect ( [ldap] User not found): [wifitest] (from client test port 0 cli 00-xx-xx-xx-xx-xx)
17:50:38 Login incorrect ( [ldap] User not found): [CED] (from client test port 0 cli 00-27-10-5A-C4-D4)
17:50:55 Login incorrect (Home Server says so): [wifitest@lamma.it] (from client test port 0 cli 00-xx-xx-xx-xx-xx)
17:50:58 Login incorrect ( [ldap] User not found): [CED] (from client test port 0 cli 00-27-10-5A-C4-D4)

Ho guardato nelle varie guide ma non sono riuscito a trovare una soluzione, mi manca il knowhow della parte kerberos e certificati sicuramente, probabilmentesbaglio proprio lì !?

simone


Ciao,
io ho il tuo stesso problema, praticamente non riesco a joinare con Zeroshell in AD per ottenere la lista degli utenti...
Un bug che ho notato è che creando un nuovo profilo, Zeroshell configura i kdc di default in modo errato. Mi piacerebbe sapere dall'autore il percorso del file krb5.conf da modificare...
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> RADIUS 802.1x e Captive Portal Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it