Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Invio email da ZeroShell 2.0.RC2

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
lpignedoli



Registrato: 12/12/12 17:47
Messaggi: 11

MessaggioInviato: Mar Gen 08, 2013 11:13 am    Oggetto: Invio email da ZeroShell 2.0.RC2 Rispondi citando

Ciao a tutti, ho un problema con ZeroShell 2.0 RC2.

Utilizzo ZS come Captive Portal in una rete, oltre a ZS ho installato anche l'interfaccia Zerotruth 0.9 per la gestione degli utenti. Il problema è che non mi manda nessun email, pur avendo configurato i parametri corretti.

Dove posso trovare il log per vedere l'errore?

Ho provato a collegarmi sulla console di zeroshell e non ho trovato il mando mail o mailx o sendmail per inviare i mail, l'unico che ho trovato è mail-files che ho provato a lanciare ma mi dà il seguente errore:

/usr/local/bin/mail-files: line 74: no: command not found

Grazie per l'aiuto.
Top
Profilo Invia messaggio privato
truthahn



Registrato: 12/06/12 11:46
Messaggi: 2225

MessaggioInviato: Mar Gen 08, 2013 11:28 am    Oggetto: Rispondi citando

Ciao, zerotruth per inviare le email si appoggia a mutt (che permette di inviare gli allegati del backup) e msmtp, che vengono installati da Zerotruth. Posta il tuo /DB/apache2/cgi-bin/zerotruth/conf/msmtprc (cancellando la password e solo il nome della tua email) che vediamo.
Grazie.
Top
Profilo Invia messaggio privato
lpignedoli



Registrato: 12/12/12 17:47
Messaggi: 11

MessaggioInviato: Mar Gen 08, 2013 11:38 am    Oggetto: Rispondi citando

Eccolo:

account Xxxxxx
host smtp.xxxxxx.it
auth on
port 25
user postmaster@xxxxxxxxx.it
password YxYxYxY
auto_from off
from postmaster@xxxxxxxxx.it
tls on
tls_starttls on
tls_certcheck off
syslog LOG_MAIL
Top
Profilo Invia messaggio privato
Francesco Steno



Registrato: 26/03/10 14:59
Messaggi: 181

MessaggioInviato: Mar Gen 08, 2013 11:50 am    Oggetto: Rispondi citando

Credo sia un problema legato alla tipologia di account di posta che stai utilizzando. Prova a creare un utente "normale" (che non sia il gestore di posta...).
Se puoi anche il contenuto dei log, sarebbe di aiuto alla soluzione del problema.

Saluti
Top
Profilo Invia messaggio privato Invia e-mail
lpignedoli



Registrato: 12/12/12 17:47
Messaggi: 11

MessaggioInviato: Mar Gen 08, 2013 11:59 am    Oggetto: Rispondi citando

Scusa ma cosa intendi con utente normale?

Il contenuto del log te lo pubblico volentieri, però non sò dovè il log.

Grazie mille.
Top
Profilo Invia messaggio privato
Francesco Steno



Registrato: 26/03/10 14:59
Messaggi: 181

MessaggioInviato: Mar Gen 08, 2013 12:24 pm    Oggetto: Rispondi citando

lpignedoli ha scritto:
Scusa ma cosa intendi con utente normale?


In teoria, l'account postmaster, può essere usato come un normale account, ma è preferibile utilizzare un'altro account di posta
per le operazioni di "routine". Quella tipologia di account, su un gestore come Aruba, ad esempio, consente la gestione degli
utenti e altre configurazioni.
Per qusto ti consigliavo di creare un altro account di posta, nel caso ti fosse possibile.... ma ripeto, è solo un mio consiglio.

lpignedoli ha scritto:
Il contenuto del log te lo pubblico volentieri, però non sò dovè il log.

Grazie mille.


Nel menu a sinistra Logs, poi nella nuova maschera in altro restringi la ricerca fino a trovare il log...
Top
Profilo Invia messaggio privato Invia e-mail
lpignedoli



Registrato: 12/12/12 17:47
Messaggi: 11

MessaggioInviato: Mar Gen 08, 2013 12:37 pm    Oggetto: Rispondi citando

Francesco Steno ha scritto:

In teoria, l'account postmaster, può essere usato come un normale account, ma è preferibile utilizzare un'altro account di posta
per le operazioni di "routine". Quella tipologia di account, su un gestore come Aruba, ad esempio, consente la gestione degli
utenti e altre configurazioni.
Per qusto ti consigliavo di creare un altro account di posta, nel caso ti fosse possibile.... ma ripeto, è solo un mio consiglio.


Ah ok. No, nel mio caso postmaster è un utente base.

Francesco Steno ha scritto:

Nel menu a sinistra Logs, poi nella nuova maschera in altro restringi la ricerca fino a trovare il log...


Ecco appunto, io li ho guardati tutti i log ma non ho trovato quello che riguarda l'invio dei mail.
Qui un print screen dei log che ho a disposizione:

Top
Profilo Invia messaggio privato
Francesco Steno



Registrato: 26/03/10 14:59
Messaggi: 181

MessaggioInviato: Mar Gen 08, 2013 12:47 pm    Oggetto: Rispondi citando

Nelle altre sezioni dei log non hai trovato qualcosa inerente l'invio delle mail ?
Potresti fare una prova, e settare quell'account con le relative credenziali, per inviare una mail da ZS ad un indirizzo di posta qualunque ? questo per darti conferma che ZS invii mail senza problemi.
Top
Profilo Invia messaggio privato Invia e-mail
lpignedoli



Registrato: 12/12/12 17:47
Messaggi: 11

MessaggioInviato: Mar Gen 08, 2013 12:59 pm    Oggetto: Rispondi citando

Francesco Steno ha scritto:
Nelle altre sezioni dei log non hai trovato qualcosa inerente l'invio delle mail ?
Potresti fare una prova, e settare quell'account con le relative credenziali, per inviare una mail da ZS ad un indirizzo di posta qualunque ? questo per darti conferma che ZS invii mail senza problemi.


No, le ho guardate tutte e non ho trovato nulla.
Come non riesco a trovare in ZS i parametri per configurare e/o inviare email.

Ho provato da console il seguente comando:

./DB/_DB.003/zerotruth_0.9/DB/apache2/cgi-bin/zerotruth/bin/msmtp --host=smtp.xxxxxx.it --user=postmaster@xxxxxxxx.it --passwordeval=YxYxYx --tls=on --auto-from=off --tls_starttls=on --tls_certcheck=off --from=postmaster@xxxxxxxx.it user@xxxxxxxxx.it

e il mail è stato inviato e ricevuto.
Top
Profilo Invia messaggio privato
truthahn



Registrato: 12/06/12 11:46
Messaggi: 2225

MessaggioInviato: Mar Gen 08, 2013 2:33 pm    Oggetto: Rispondi citando

Nei log non trovi nulla perche zeroshell non ha la possibilità di inviare email, come detto mutt e msmtp li installa zerotruth...
cambia quel
account Xxxxxx
con
account default
e prova.
Top
Profilo Invia messaggio privato
lpignedoli



Registrato: 12/12/12 17:47
Messaggi: 11

MessaggioInviato: Mar Gen 08, 2013 2:49 pm    Oggetto: Rispondi citando

truthahn ha scritto:
Nei log non trovi nulla perche zeroshell non ha la possibilità di inviare email, come detto mutt e msmtp li installa zerotruth...
cambia quel
account Xxxxxx
con
account default
e prova.


Grande funziona!!!!! Very Happy Very Happy Very Happy

Grazie mille
Top
Profilo Invia messaggio privato
Francesco Steno



Registrato: 26/03/10 14:59
Messaggi: 181

MessaggioInviato: Mar Gen 08, 2013 7:48 pm    Oggetto: Rispondi citando

truthahn ha scritto:
Nei log non trovi nulla perche zeroshell non ha la possibilità di inviare email, come detto mutt e msmtp li installa zerotruth...


Per l'appunto. Io non ho mai usato zerotruth, ma da da quello che ho letto negli altri post, in seguito all'installazione si ha nel sistema anche mutt e msmtp,
quindi da ssh con una shell si dovrebbe poter lanciare mutt e/o msmtp, e di coneguenza si ha la possibilità di inviare una mail ...
dico un eresia ?
Se si installa zerot. si può da una shell usare mutt e/o msmtp ?
Top
Profilo Invia messaggio privato Invia e-mail
lpignedoli



Registrato: 12/12/12 17:47
Messaggi: 11

MessaggioInviato: Mer Gen 09, 2013 8:51 am    Oggetto: Rispondi citando

Francesco Steno ha scritto:
truthahn ha scritto:
Nei log non trovi nulla perche zeroshell non ha la possibilità di inviare email, come detto mutt e msmtp li installa zerotruth...


Per l'appunto. Io non ho mai usato zerotruth, ma da da quello che ho letto negli altri post, in seguito all'installazione si ha nel sistema anche mutt e msmtp,
quindi da ssh con una shell si dovrebbe poter lanciare mutt e/o msmtp, e di coneguenza si ha la possibilità di inviare una mail ...
dico un eresia ?
Se si installa zerot. si può da una shell usare mutt e/o msmtp ?


No, non dici nessuna eresia, tantè che io per effettuare il test che l'invio del mail funzionasse mi mandavo i mail da shell.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it