Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Filtri Layer 7

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
flavietto_it



Registrato: 25/10/13 22:46
Messaggi: 14

MessaggioInviato: Mar Mag 27, 2014 12:45 am    Oggetto: Filtri Layer 7 Rispondi citando

Rieccomi qua, ho un problemone grosso grosso che non riesco proprio a risolvere nonostrante abbia investito diverse sere e nonostante abbia letto tanta tanta documentazione e post vari.

In nessun modo riesco a far andare i filtri layer 7.

Dapprima con i filtri di default installati sulla 3.0 e poi con un tentativo di aggiornamento di filtri del 2008, quando apro la scheda QOS > L7 Filter ho le voci tutte commentate, anche se andando a vedere dalla console il file di mio interesse (bittorrent ad esempio) non ci sono i commenti su un paio di righe, tra qui quella della regola appunto.

Naturalmente loggando, il traffico interessato fluisce liberamente finendo nell'ultima regola di default e non viene in alcun modo intercettato da quella giusta.

Ecco qui la regola correttamente inserita:
-A QoS -m layer7--l7proto bittorrent -m limit --limit 10/min --limit-burst 15 -j LOG --log-prefix "QoS/047"
-A QoS -m layer7--l7proto bittorrent -j MARK --set-xmark 0x11/0xffffffff

Help please, non so proprio come venirne fuori.

Grazie mille.
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Mar Mag 27, 2014 8:06 am    Oggetto: Rispondi citando

prova ad abilitare il not sul filtro l7 nelle regole fw, a me cosi funziona ho fatto un test sul protocollo pop3, se abiliti il not blocca altrimenti tutto passa, almeno a me.
Top
Profilo Invia messaggio privato
flavietto_it



Registrato: 25/10/13 22:46
Messaggi: 14

MessaggioInviato: Mar Mag 27, 2014 9:30 am    Oggetto: Rispondi citando

Sei sicuro che funzioni?

Con il NOT abilitato dovrebbe escludere quella condizione e di conseguenza includere tutte le altre. Il risultato sarebbe che tutto il traffico verrebbe intercettato dalla regola, ma non quello interessato.

Sulla mia 3.0 altre regole dove utilizzo il NOT, i log mi dicono questo.

Tutto questo salvo che non mi stia rimbambendo del tutto Confused
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Mar Mag 27, 2014 11:38 am    Oggetto: Rispondi citando

infatti e vero quello che dici e anche io non capisco perchè, se abilito il not sulla regola del filter tutti i download per esempio torrent si bloccano e non vanno pù, se non lo abilito non intercetta niente, sembra che lavori al contrario.

altra cosa se abiliti il not su dei filtri anche al navigazione di certi siti si blocca a me succede con google.. non capisco perchè.

io questo posso dirti e rimango bloccato anche io purtroppo Mad Rolling Eyes
Top
Profilo Invia messaggio privato
flavietto_it



Registrato: 25/10/13 22:46
Messaggi: 14

MessaggioInviato: Mer Mag 28, 2014 9:22 am    Oggetto: Rispondi citando

Mi sembra strano che Fulvio abbia tralasciato una cosa del genere.
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Dom Giu 01, 2014 1:12 pm    Oggetto: Rispondi citando

Sei riuscito a trovare una soluzione?
Top
Profilo Invia messaggio privato
flavietto_it



Registrato: 25/10/13 22:46
Messaggi: 14

MessaggioInviato: Dom Giu 01, 2014 6:41 pm    Oggetto: Rispondi citando

No, per ora mi sono limitato a utilizzare l'ultima regola, quella di default come "ghigliottina" per tutto ciò che non è classificato. L'ho messa in low priority e con banda massima di 0.5M e sembra funzionare. Qualche sera provo a ridurre ulteriormente. La mia intenzione non è privare del tutto, ma lasciare un minimo di banda per fare in modo che i client di vario tipo non diano errore.
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Lun Giu 02, 2014 9:15 am    Oggetto: Rispondi citando

Ciao posso sapere che regola hai creato? e come? tanto per capirci qualcosa di più
Top
Profilo Invia messaggio privato
andrea_vale



Registrato: 05/06/14 22:25
Messaggi: 2

MessaggioInviato: Gio Giu 05, 2014 10:27 pm    Oggetto: Rispondi citando

Ciao a tutti.
Ho iniziato da poco a utilizzare zeroshell e anche io non riesco a fare funzionare i filtri di L7-filter.
Avete risolto?
Grazie.
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Ven Giu 06, 2014 12:50 pm    Oggetto: Rispondi citando

ciao io purtroppo l'unico modo che ho trovato x far funzionare i filtri e l'applicazione del not xo non sarebbe giusto a rigor di logica ma purtroppo x me e al momento l'unica soluzione.
Top
Profilo Invia messaggio privato
andrea_vale



Registrato: 05/06/14 22:25
Messaggi: 2

MessaggioInviato: Lun Giu 09, 2014 11:13 am    Oggetto: Rispondi citando

Ho fatto un po di ricerche ed ho scoperto che l'ultima versione in cui funziona l7-filter è la 1.0.beta16.

Se vedete questa discussione sembrerebbe che il problema sta sull'incompatibilità della versione del kernel:
http://www.zeroshell.org/forum/viewtopic.php?p=12350#12350

In effetti ho notato che se da shell chiamo "man iptables" sulla 2.0RC e 3.0.0 non mi spunta l'estensione layer7, mentre su 1.0.beta16 mi spunta correttamente.
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Mer Giu 11, 2014 12:49 pm    Oggetto: Rispondi citando

andrea_vale ha scritto:
Ho fatto un po di ricerche ed ho scoperto che l'ultima versione in cui funziona l7-filter è la 1.0.beta16.

Se vedete questa discussione sembrerebbe che il problema sta sull'incompatibilità della versione del kernel:
http://www.zeroshell.org/forum/viewtopic.php?p=12350#12350

In effetti ho notato che se da shell chiamo "man iptables" sulla 2.0RC e 3.0.0 non mi spunta l'estensione layer7, mentre su 1.0.beta16 mi spunta correttamente.


ciao, mi sembrava che c'era qualcosa che non andava..

e quindi sarebbe da riscrivere il kernel? non è che si può modificare in qualche modo?
di conseguenza non funzionano neanke nel QoS..
parola agli esperti.. Cool
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Lun Giu 16, 2014 8:58 am    Oggetto: Rispondi citando

ciao a tutti

constatato che i filtri non vanno, vorrei sapere se devo esentare un pc ad una regola come posso fare.

per esempio pc non si deve collegare ad internet tranne per il protocollo pop3, bisognerebbe usare il not ma non funziona.

come posso fare??
Top
Profilo Invia messaggio privato
maverick



Registrato: 18/03/14 17:25
Messaggi: 509

MessaggioInviato: Mar Lug 01, 2014 7:40 am    Oggetto: Rispondi citando

buon giorno

avrei bisogno del vostro aiuto.

io ho creato una macchina che è bloccata sulla navigazione però avrei bisogno che questa macchina possa solo scaricare la posta elettronica quindi tornerebbero utili i filtri L7 che però a quanto so non funzionano.

qualcuno mi può aiutare su come eseguire il download della posta eletronica (pop3 e smtp) su questa configurazione che ho
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it