Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Log troncato?

 
Nuovo argomento   Rispondi    Indice del forum -> Segnalazione BUG
Precedente :: Successivo  
Autore Messaggio
deafbear



Registrato: 29/04/08 20:43
Messaggi: 9

MessaggioInviato: Mar Apr 29, 2008 9:21 pm    Oggetto: Log troncato? Rispondi citando

Anzitutto mi complimento per l'ottimo lavoro e la disponibilità a condividere il proprio progetto.
Mi permetto di segnalare una cosa relativa ai log. Sono un po' incerto dato che molti stanno usando questa funzione e sembra non abbiano riscontrato problemi, o meglio, non ho trovato alcuna segnalazione nel forum. Magari è proprio richiesto che sia così, per cui porta pazienza.
Ho scaricato la versione 1.0.b9 come immagine vmware. Mi serviva usare la funzione di log server per monitorare un paio di apparati, in particolare ho testato un router Netgear e due ata Linksys.
Interfaccia chiara e semplice da configurare, per cui il server è andato a posto in pochi minuti. Sugli scatolotti da controllare bastava impostare l'indirizzo ip del server e il livello di dettaglio del log.
Mi accorgo però che i log sono tronchi nella parte iniziale del messaggio. Riporto un piccolo esempio (date e ore ovviamente non corrispondono).

Router Netgear, dalla sua interfaccia di amministazione:
Codice:
Sun, 2002-09-08 13:00:45 - CHAP authentication success
Sun, 2002-09-08 13:00:57 - Send out NTP request to time-g.netgear.com
Mon, 2008-04-28 23:18:24 - Receive NTP Reply from time-g.netgear.com
Mon, 2008-04-28 23:19:20 - <DDNS>Update OK: good
Mon, 2008-04-28 23:26:02 - Administrator login successful - IP:192.168.4.3


Stessa procedura, un semplice avvio, registrata dal log di ZeroShell:
Codice:
01:00:03 authentication success
01:00:14 out NTP request to time-g.netgear.com
01:00:15 NTP Reply from time-g.netgear.com
01:01:12 OK: good
01:20:38 login successful - IP:192.168.4.3


Una piccola, anzi grossa, differenza è che gli orari del primo sono quelli del router e infatti fin quando non sincronizza l'ora sono sballati, nel secondo sono quelli di ricezione del messaggio.

Un secondo esempio, giusto per capire se dipendeva dall'apparato che magari non inviava correttamente le informazioni.

Ata Linksys, recuperato tramite Kiwi syslog:
Codice:
2008-04-29 18:06:53   Local0.Info   [1]->192.168.2.4:5060(336)
2008-04-29 18:06:53   Local0.Info   [1]->192.168.2.4:5060(336)
2008-04-29 18:06:53   Local7.Debug   NOTIFY sip:192.168.2.4 SIP/2.0<013><010>Via: SIP/2.0/UDP 192.168.2.4:5061;branch=z9hG4bK-28083066<013><010>From: SPA PSTN <sip:spa3102@192.168.2.4>;tag=21c9091814bdfdf4o1<013><010>To: <sip:192.168.2.4><013><010>Call-ID: 52a42ec8-f48d9404@192.168.2.4<013><010>CSeq: 1122 NOTIFY<013><010>Max-Forwards: 70<013><010>Event: keep-alive<013><010>User-Agent: Linksys/SPA3102-5.1.5(GWa)<013><010>Content-Length: 0
2008-04-29 18:06:53   Local0.Info   <010>
2008-04-29 18:06:53   Local0.Info   <010>
2008-04-29 18:06:53   Local0.Info   [1]<<127.0.0.1:5060(309)
2008-04-29 18:06:53   Local0.Info   [1]<<127.0.0.1:5060(309)
2008-04-29 18:06:53   Local7.Debug   SIP/2.0 404 Not Found<013><010>To: <sip:192.168.2.4>;tag=f436a508731392c4i0<013><010>From: SPA PSTN <sip:spa3102@192.168.2.4>;tag=21c9091814bdfdf4o1<013><010>Call-ID: 52a42ec8-f48d9404@192.168.2.4<013><010>CSeq: 1122 NOTIFY<013><010>Via: SIP/2.0/UDP 192.168.2.4:5061;branch=z9hG4bK-28083066<013><010>Server: Linksys/SPA3102-5.1.5(GWa)<013><010>Content-Length: 0


e la stessa situazione, stand by e messaggio di keep alive, registrata da ZeroShell:
Codice:
21:36:54
21:36:54
21:36:54 sip:192.168.2.4 SIP/2.0^M Via: SIP/2.0/UDP 192.168.2.4:5061;branch=z9hG4bK-a4de7572^M From: SPA PSTN ;tag=21c9091814bdfdf4o1^M To: ^M Call-ID: 52a42ec8-f48d9404@192.168.2.4^M CSeq: 1969 NOTIFY^M Max-Forwards: 70^M Event: keep-alive^M User-Agent: Linksys/SPA3102-5.1.5(GWa)^M Content-Length: 0^M ^M
21:36:54
21:36:54
21:36:54
21:36:54
21:36:54 404 Not Found^M To: ;tag=f436a508731392c4i0^M From: SPA PSTN ;tag=21c9091814bdfdf4o1^M Call-ID: 52a42ec8-f48d9404@192.168.2.4^M CSeq: 1969 NOTIFY^M Via: SIP/2.0/UDP 192.168.2.4:5061;branch=z9hG4bK-a4de7572^M Server: Linksys/SPA3102-5.1.5(GWa)^M Content-Length: 0^M ^M


Spero sia sufficientemente comprensibile. Nel primo manca l'inizio di ogni messaggio, nel secondo alcune parti all'interno del messaggio. Una differenza è che mentre kiwi mette i codici di carattere racchiusi tra "<>" (<013><010>), ZeroShell probabilmente rappresenta quegli stessi caratteri. Ma così perde anche indirizzi ip, come all'inizio del messaggio:

    2008-04-29 18:06:53 Local7.Debug SIP/2.0 404 Not Found<013><010>To: <sip:192.168.2.4>;tag=
    21:36:54 404 Not Found^M To: ;tag=


Non so se è una scelta tecnica, un problema di acquisizione del messaggio, di conservazione o di rappresentazione, ma credo sia un problema.
In caso contrario scusate, non sono un esperto purtroppo.
Saluti e grazie per l'attenzione
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1559

MessaggioInviato: Mar Apr 29, 2008 10:27 pm    Oggetto: Rispondi citando

Non si tratta chiaramente di una scelta tecnica. Vedrò di porvi rimedio quanto prima.

Grazie della segnalazione
Fulvio
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> Segnalazione BUG Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it