Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Beta11 & forward

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
acastellani



Registrato: 25/07/07 10:45
Messaggi: 10

MessaggioInviato: Ven Nov 14, 2008 3:32 pm    Oggetto: Beta11 & forward Rispondi citando

E' tutto stamanttina che preparo un pc con la beta 11, visto che finalmente posso fare il balancing delle mie 3 linee (grazie Fulvio, lo aspettavo).
Il default gateway e' impostato, assegno gli stessi ip (a pc spento per i conflitti), metto il DB su una chiavetta usb... tutto pronto, insomma.
Vado a sostituire il gateway con il nuovo pc e mi accorgo che i pacchetti non transitano dalla lan all'esteno, mentre la zeroshell esce tranquillamente in internet.
In lan il nuovo gateway risponde ai ping, ma non lascia passare nulla (ad es. ping a ip statici), ne' risolve i nomi DNS esterni.
Non ricordando impostazioni particolari grazie alle quali precedente la beta 9 mi funziono' subito, verifico la regola della catena forward, che pero' e' normalmente su : Accept.
Spengo pure il firewall.. niente.
Sono costretto a ripristinare il vecchio gateway con la beta 9 e tutto riparte (3 linee con route statica per un bilanciamento "molto manuale").
Purtroppo non ho avuto il tempo in una mezzora di fare molte altre prove.
Insomma, sembra mancare il classico: echo 1 > /proc/sys/net/ipv4/ip_forward
Faro' una figuraccia e capisco di non dare molti dettagli, ma chiedo: a naso, ho dimenticato di impostare qualcosa ? Sad
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Ven Nov 14, 2008 5:32 pm    Oggetto: Rispondi citando

Non credo che /proc/sys/net/ipv4/ip_forward sia diverso da 1. Comunque dai il

cat /proc/sys/net/ipv4/ip_forward

e verifica. Non si sa mai.

Ricordati invece, che tutte le interfacce di rete che vanno verso Internet devono essere poste in MASQUERADE da [Router][NAT].

Se non fosse questo il problema, devi scegliere se indagare con calma oppure ricrearti un nuovo profilo.

Ciao
Fulvio
Top
Profilo Invia messaggio privato
acastellani



Registrato: 25/07/07 10:45
Messaggi: 10

MessaggioInviato: Sab Nov 15, 2008 12:44 pm    Oggetto: Rispondi citando

Eccolo qua'...
Pensando ad una sostituzione indolore di pochi minuti e preso invece dalla fretta per aver indotto un black-out di internet, non ho completato le mie indagini.
Penso che sia quello che dici tu, Fulvio, in nat (banalmente).
Grazie e scusami.
A.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it