Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

openVPN e ping instabile

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
Vanni



Registrato: 12/03/09 10:35
Messaggi: 5

MessaggioInviato: Ven Mar 13, 2009 1:26 pm    Oggetto: openVPN e ping instabile Rispondi citando

Ciao a tutti!

Prima di tutto complimenti a Fulvio per lo straordinario lavoro di integrazione e creazione di una interfaccia web così facile da usare per una serie di funzioni molto avanzate come quelle messe a disposizione da Zeroshell.

Ora veniamo alle domande. Sto installando delle macchine presso sedi remote e voglio poter permettere ad alcuni utenti di entrare nella locale rete attraverso un tunnel cifrato fatto con zeroshell in sede e openvpn portable a lato client.

Ho configurato un utente ed una macchina remota, ho esportato i loro certificati, ho modificato il file .ovpn fornito come esempio e mi collego da remoto alla vpn.
Quando però cerco di agire, anche solo richiedendo un ping sul default gateway della vpn i tempi di risposta sono instabili, a differenza dei ping sull'indirizzo ip del router. In media salta un 36% dei pacchetti. La connessione internet invece non ne salta nessuno.

Che voi sappiate ci sono delle impostazioni particolari da inserire per rendere più stabile la connessione vpn?

Che prove posso fare per diagnosticare quel'è l'incertezza in cui inciampa la vpn?

Uso un PC PIII 800 con 256 mb di ram e 3 schede ethernet RTL8139D

Grazie a tutti
Vanni

--- --- --- EDIT --- --- ---
mi sono accorto solo ora che nel log di avvio ho le seguenti righe, è normale? C'entra?

Codice:

kerbynet[10016]: segfault at a1f7000 ip b7d29de6 sp bfc02bf8 error 4 in libc-2.8.so[b7cb7000+139000]
kerbynet[25331]: segfault at 8194f3a ip b7f9ac27 sp bf8f4370 error 7 in libstdc++.so.5.0.5[b7f1b000+9e000]
kerbynet[21389]: segfault at bfd00000 ip b7eebe56 sp bfdcd940 error 4 in libc-2.8.so[b7e80000+139000]
Top
Profilo Invia messaggio privato
ufoonline



Registrato: 03/07/08 22:16
Messaggi: 261

MessaggioInviato: Lun Mar 16, 2009 11:55 pm    Oggetto: Rispondi citando

scusami.. "la connessione internet non ne salta nessuno" intendi che pingado invece la macchina ZS da remoto non perde i pacchetti?

Perchè è strano.. io ho avuto questi problemi solo quando c'erano problemi di routing.

Calcola che io utilizzo ZS per accedere ai server dietro NAT dei clienti, utilizzando ZS da VPN Concentrator.. ed avvolte (come ieri) lavoro tramite VPN collegandomi con l'ufficio e trasferisco file con i server remoti senza problemi.
Top
Profilo Invia messaggio privato
Vanni



Registrato: 12/03/09 10:35
Messaggi: 5

MessaggioInviato: Mer Mar 18, 2009 10:31 am    Oggetto: Rispondi citando

Ciao

Grazie della risposta.

Sto cominciando a capire meglio come funziona, anche grazie ad altri post del forum che prima non avevo trovato.

Vediamo se riesco a spiegare meglio la mia situazione dato che temo di averne fatto una descrizione troppo sommaria.

Ho trovato Zeroshell fantastico e ho subito dedicato un vecchio pc FSC PIII800 con 256 MB di RAM al ruolo di Load Balancing and Failover tra le due ADSL dell'ufficio. Ho installato tre schede RTL8139C di cui una (ETH00) dedicata alla LAN con IP 192.168.168.254 e le altre due alla comunicazione con i due Router ADSL (Telecom su ETH01 e NGI su ETH02).
Tutto ha funzionato bene e funziona ancora, a parte alcuni siti che non mantengono la sessione (per esempio la webmail di libero) e la fanno scadere dato che vedono pacchetti arrivare dal un IP diverso da quello che aveva avviato la sessione. Ma questo spero di averlo risolto definendo un peso diverso per i router e privilegiandone uno. Meglio perdere il load balancing che avere problemi di affidabilità di connessione.

I problemi sono iniziati quando ho deciso di provare a far fare da ponte per le VPN alla zeroshell. Ho deciso di usare l'autenticazione solo coi certificati per semplificare la vita agli utenti e ne ho generato uno per le prove che ho messo assieme alla chiave in una cartella di configurazione per OpenVPN Portable. Poi ho preso la cofigurazione di esempio fornita da Fulvio (grazie) e l'ho modificata per fare quello che volevo.
Dato che ho un IP statico avevo pensato di usare quello per avviare le connessioni, che infatti vengono correttamente negoziate da un client fuori dalla rete.
Solo che dopo la fase di assegnazione indirizzo, avviando un ping su IP internet le risposte sono stabili, sul default GW della rete VPN invece no.
Devo avere sbagliato il routing dei pacchetti anche a causa della presenza del load balancing.
Top
Profilo Invia messaggio privato
ufoonline



Registrato: 03/07/08 22:16
Messaggi: 261

MessaggioInviato: Dom Mar 22, 2009 11:19 pm    Oggetto: Rispondi citando

SI infatti, dovesti provare ad isabilitare il loadbalancing e vedere se funziona tutto normalmente.. se si, allora il problema è il solito.. che se siavvia la sessione su di un gw, per motivi strani si cammina anche sull'altro. e li nn ti posso aiutare.
Top
Profilo Invia messaggio privato
Arioch



Registrato: 22/07/08 14:33
Messaggi: 37

MessaggioInviato: Mar Mar 24, 2009 4:36 pm    Oggetto: Rispondi citando

Per quel che riguarda i pacchetti in ingresso per la vpn host-to-lan ho risolto permettendo l'ingresso dei pacchetti tramite un solo gw, ossia nelle balancing rules ho configurato una regola che obbliga a passare da uno solo dei 2.
Ovviamente sull'altro non va, e nel caso vada giù la linea sui cui hai fatto questo bind di porta la vpn non va su.

Se un giorno Fulvio (santo subito!!! Laughing ) marcherà i pacchetti in ingresso allora il problema dovrebbe risolversi.
Top
Profilo Invia messaggio privato
Vanni



Registrato: 12/03/09 10:35
Messaggi: 5

MessaggioInviato: Mer Mar 25, 2009 9:56 am    Oggetto: Rispondi citando

@Arioch:

Puoi scrivere come hai creato la regola, con quali parametri? Grazie
Top
Profilo Invia messaggio privato
Arioch



Registrato: 22/07/08 14:33
Messaggi: 37

MessaggioInviato: Gio Mar 26, 2009 2:51 pm    Oggetto: Rispondi citando

Allora nel balancing rules ho selezionato il protocollo TCP e inserito nel box "Source Port" la porta tcp che ho configurato per la vpn host-to-lan e come Target Gateway ho selezionato quello da cui voglio far entrare il traffico in questione.
Come Source IP non ho messo nulla cosi ogni IP dall'esterno può collegarsi.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it