Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

configurazione vodafone internet key

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
giuliano



Registrato: 06/12/06 08:26
Messaggi: 73

MessaggioInviato: Gio Ott 23, 2008 3:26 pm    Oggetto: configurazione vodafone internet key Rispondi citando

Ciao a tutti,
qualcuno è riuscito a far funzionare la vodafone internet key con zs ?

impostando
apn: web.omnitel.it
dial string *99***1# o *99***61#

e lasciando le altrei impostazioni sul default mi da sempre questo errore:

Codice:

16:25:50    pppd 2.4.3 started by root, uid 0
16:25:51    Connect script failed
16:25:51    Exit.


qualche idea ? Question

grazie

giuliano
Top
Profilo Invia messaggio privato
orko



Registrato: 03/10/08 10:55
Messaggi: 8

MessaggioInviato: Ven Ott 24, 2008 11:19 am    Oggetto: Rispondi citando

per prima cosa si potrebbe controllare se effetivamente zeroshell la riconsoce

posta un dmesg
Top
Profilo Invia messaggio privato
giuliano



Registrato: 06/12/06 08:26
Messaggi: 73

MessaggioInviato: Ven Ott 24, 2008 12:32 pm    Oggetto: Rispondi citando

giusto Smile

Codice:

...
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
hub 1-0:1.0: unable to enumerate USB device on port 2
usb 2-2: new full speed USB device using ohci_hcd and address 2
usb 2-2: configuration #1 chosen from 1 choice
usb 2-2: New USB device found, idVendor=12d1, idProduct=1003
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-2: Product: HUAWEI Mobile
usb 2-2: Manufacturer: HUAWEI Technologies
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
usb 2-2: USB disconnect, address 2
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usbcore: registered new interface driver ub
hub 1-0:1.0: unable to enumerate USB device on port 2
usb 2-2: new full speed USB device using ohci_hcd and address 3
usb 2-2: configuration #1 chosen from 1 choice
usb-storage: probe of 2-2:1.0 failed with error -5
usb-storage: probe of 2-2:1.1 failed with error -5
scsi3 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usb 2-2: New USB device found, idVendor=12d1, idProduct=1003
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 2-2: Product: HUAWEI Mobile
usb 2-2: Manufacturer: HUAWEI Technologies
usbcore: registered new interface driver usbserial
drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
drivers/usb/serial/usb-serial.c: USB Serial Driver core
drivers/usb/serial/usb-serial.c: USB Serial support registered for GSM modem (1-port)
option 2-2:1.0: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB0
option 2-2:1.1: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB1
usbcore: registered new interface driver option
drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.1
scsi 3:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 2
scsi 3:0:0:0: Attached scsi generic sg0 type 5
usb-storage: device scan complete
Driver 'sr' needs updating - please use bus_type methods
sr0: scsi-1 drive
Uniform CD-ROM driver Revision: 3.20
sr 3:0:0:0: Attached scsi CD-ROM sr0


direi che il modem è riconosciuto Smile
Top
Profilo Invia messaggio privato
orko



Registrato: 03/10/08 10:55
Messaggi: 8

MessaggioInviato: Ven Ott 24, 2008 4:51 pm    Oggetto: Rispondi citando

hai già provato tutte e due le porte immagino, sia ttyUSB0 e ttyUSB1?

già che ci sei, posta pure il log della chat....che vedo che errore ti da lì
Top
Profilo Invia messaggio privato
argaar



Registrato: 21/11/07 10:48
Messaggi: 115
Residenza: Roma

MessaggioInviato: Ven Ott 24, 2008 5:46 pm    Oggetto: Rispondi citando

hai provato anche con *99***16#

nota è 16 e non 61 come hai riportato te..
_________________
Noi esploriamo... e ci chiamate criminali. Noi cerchiamo conoscenza... e ci chiamate criminali. Noi esistiamo senza colore di pelle, nazionalita', credi religiosi e ci chiamate criminali.
Top
Profilo Invia messaggio privato
giuliano



Registrato: 06/12/06 08:26
Messaggi: 73

MessaggioInviato: Ven Ott 24, 2008 5:51 pm    Oggetto: Rispondi citando

si si ho provato entrambe le porte.
lod chat:
Codice:

18:49:32    abort on (BUSY)
18:49:32    abort on (NO CARRIER)
18:49:32    abort on (ERROR)
18:49:32    report (CONNECT)
18:49:32    timeout set to 15 seconds
18:49:32    send (AT^M)
18:49:32    expect (OK)
18:49:32    AT^M^M
18:49:32    OK
18:49:32    -- got it
18:49:32    send (AT+CGDCONT=1,"IP","web.omnitel.it","",0,0^M)
18:49:32    expect (OK)
18:49:32    ^M
18:49:32    AT+CGDCONT=1,"IP","web.omnitel.it","",0,0^M^M
18:49:32    +CME ERROR
18:49:32    -- failed
18:49:32    Failed (ERROR)



ho anche notato che se ci sono dei doppi apici la optional AT string non viene caricata correttamente nell'interfaccia web

grazie

giuliano
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Ven Ott 24, 2008 7:29 pm    Oggetto: Rispondi citando

Sei sicuro di dover proprio usare la Optional AT String. Serve solo in casi particolari in cui bisogna inizializzare il modem.

Ciao
Fulvio
Top
Profilo Invia messaggio privato
giuliano



Registrato: 06/12/06 08:26
Messaggi: 73

MessaggioInviato: Ven Ott 24, 2008 8:27 pm    Oggetto: Rispondi citando

ho provato anche senza optional string.l'errore riportato sopraè senza stringa, ma prima ho provato diverse stringhe senza successo.
Come si imposta il pin della sim ? Magari è quello...


L'ultima modifica di giuliano il Ven Ott 24, 2008 8:36 pm, modificato 1 volta
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Ven Ott 24, 2008 8:36 pm    Oggetto: Rispondi citando

Prova il comando

comgt -d /udev/ttyUSB1

per capire se il modem quanto meno si registra alla rete mobile.

Ciao
Fulvio
Top
Profilo Invia messaggio privato
giuliano



Registrato: 06/12/06 08:26
Messaggi: 73

MessaggioInviato: Ven Ott 24, 2008 9:16 pm    Oggetto: Rispondi citando

come pensavo mi chiede il pin ...

Codice:

comgt -d /udev/ttyUSB1

Enter PIN number: 0058
Waiting for Registration..(120 sec max)..
Registered on Home network: "22210",2
Signal Quality: 15,99


dopo un po di temtativi mi da connesso Smile come posso impostare il pin in automatico al riavvio ?
per ora aggiungo un
echo 0058 | comgt -d /udev/ttyUSB1
all'avvio e parto con la chiavetta inserita. c'è un modo più pulito ? tipo usando udev...
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Dom Ott 26, 2008 10:40 am    Oggetto: Rispondi citando

Nel forum in Inglese, guarda il post http://www.zeroshell.net/eng/forum/viewtopic.php?t=723
Il tizio sembra risolvere il problema dello sblocco della SIM protetta da PIN, mettendo

AT+CPIN=XXXX

nella voce di configurazione "Optional AT string".
Fammi sapere se funziona, così lo aggiungo nella documentazione.

Ciao
Fuvio
Top
Profilo Invia messaggio privato
giuliano



Registrato: 06/12/06 08:26
Messaggi: 73

MessaggioInviato: Lun Ott 27, 2008 8:29 am    Oggetto: Rispondi citando

Ciao,
a me non funziona...

Codice:

08:26:15    abort on (BUSY)
08:26:15    abort on (NO CARRIER)
08:26:15    abort on (ERROR)
08:26:15    report (CONNECT)
08:26:15    timeout set to 15 seconds
08:26:15    send (AT^M)
08:26:15    expect (OK)
08:26:15    AT^M^M
08:26:15    OK
08:26:15    -- got it
08:26:15    send (AT+CPIN=0058^M)
08:26:15    expect (OK)
08:26:15    ^M
08:26:15    AT+CPIN=0058^M^M
08:26:15    +CME ERROR
08:26:15    -- failed
08:26:15    Failed (ERROR)
Top
Profilo Invia messaggio privato
argaar



Registrato: 21/11/07 10:48
Messaggi: 115
Residenza: Roma

MessaggioInviato: Lun Ott 27, 2008 9:16 am    Oggetto: Rispondi citando

io ho risolto togliendogli il pin dall'interfaccia della vodafone su windows...
_________________
Noi esploriamo... e ci chiamate criminali. Noi cerchiamo conoscenza... e ci chiamate criminali. Noi esistiamo senza colore di pelle, nazionalita', credi religiosi e ci chiamate criminali.
Top
Profilo Invia messaggio privato
danieleb



Registrato: 08/04/09 23:46
Messaggi: 5

MessaggioInviato: Ven Apr 10, 2009 4:35 pm    Oggetto: Rispondi citando

novità? ho lo stesso problema con un K3715..ho gli stessi messaggi di errori nella log chat.. Crying or Very sad
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it