Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

IPSec NAT-T

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
cilo



Registrato: 18/04/07 20:23
Messaggi: 1
Residenza: Milano

MessaggioInviato: Lun Apr 23, 2007 8:31 pm    Oggetto: IPSec NAT-T Rispondi citando

Salve a tutti! Sto sperimentando la beta4 di Zeroshell, è veramente un bel progetto, tanti complimenti al suo creatore! (Fulvio se esci dalla beta puoi attivare le donazioni attraverso paypal, sarebbero tutte meritate Smile
Ho configurato la vpn host-to-lan in una configurazione di laboratorio e mi funziona molto bene, però adesso dovrei usarla in un contesto diverso ovvero: io dovrei collegarmi da casa (connessione fastweb con NAT), il server Zeroshell dovrebbe stare in ufficio collegato ad un router Albacom che anch'esso implementa il NAT (il router ha già un ip pubblico ed uno privato).
Immagino che dovrei abilitare IPSec NAT-T per aver qualche speranza che la connessione vada a buon fine, ma ho qualche speranza di farlo funzionare? Oppure è proprio assente l'implementazione del NAT-T? Leggendo alcuni thread passati sembra si riesca a farlo funzionare.
Ciao, Danilo.
Top
Profilo Invia messaggio privato Invia e-mail
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Gio Apr 26, 2007 8:25 pm    Oggetto: Rispondi citando

Il NAT-T viene effettivamente attivato da ZeroShell quando si spunta l'apposita checkbox. Tuttavia, quando feci le prove (sulla beta1 con kernel 2.6.16) ebbi dei problemi, forse dovuti all'implementazione di IPSec nel Kernel. Per questo motivo, se si configura il NAT-T sulle VPN L2TP/IPSec viene riportato un warning, indicante che la cosa potrebbe non funzionare correttamente.
Dalla beta3, Zeroshell parte con un Kernel 2.6.19 e le cose potrebbero essere cambiate. Qualcuno mi ha fatto notare che con la beta3 il NAT-T ha funzionato mentre con la beta4 risulta nuovamente non funzionante. Penso di dover riguardare le VPN l2tp/ipsec prossimamente.

Cia
Fulvio
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it