Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Forward Box

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
Sethi



Registrato: 24/05/07 21:07
Messaggi: 16

MessaggioInviato: Gio Mag 24, 2007 9:20 pm    Oggetto: Forward Box Rispondi citando

Ciao a tutti, ho a disposizione un IP pubblico e qualche schedina embedded dislocata su una rete locale. Vorrei mettere una zeroshell box che mi faccia da tramite e mappare un tot di porte sul serve pubblico reinstradando sulla posta delle schedine embedded in locale.
Ho configurato le due interfacce di rete, messo il gateway alla scheda in pubblica, abilitato il masq tra la rete locale e la pubblica e infine impostato tutti i vari "Port Fowarding" tramite la funzione "Virtual Server". Ecco il risultato:

Citazione:

Chain PREROUTING (policy ACCEPT 298 packets, 22170 bytes)
pkts bytes target prot opt in out source destination
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22000 to:10.140.1.6:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22001 to:10.140.1.15:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22002 to:10.140.1.10:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22003 to:10.140.1.16:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22004 to:10.140.1.14:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22005 to:10.140.1.7:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22006 to:10.140.1.11:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22007 to:10.140.1.24:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22008 to:10.140.1.22:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22009 to:10.140.1.18:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22010 to:10.140.1.19:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22011 to:10.140.1.20:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22012 to:10.140.1.12:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22013 to:10.137.4.2:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22014 to:10.137.24.1:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22015 to:10.137.6.2:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22016 to:10.140.2.16:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22017 to:10.140.1.27:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22018 to:10.137.4.10:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22019 to:10.140.1.9:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22020 to:10.137.14.1:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22022 to:10.137.32.1:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22023 to:10.137.28.1:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22024 to:10.137.36.1:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22025 to:10.140.1.15:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22026 to:10.140.1.50:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22027 to:10.67.4.1:1091
0 0 DNAT tcp -- ETH01 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:22021 to:10.137.14.1:1091

Chain POSTROUTING (policy ACCEPT 32 packets, 2680 bytes)
pkts bytes target prot opt in out source destination
47 3820 SNATVS all -- * * 0.0.0.0/0 0.0.0.0/0
15 1140 MASQUERADE all -- * ETH01 0.0.0.0/0 0.0.0.0/0

Chain SNATVS (1 references)
pkts bytes target prot opt in out source destination
0 0 MASQUERADE all -- * * 0.0.0.0/0 0.0.0.0/0 MARK match 0xff1973




Teoricamente non mi serve altro. Può bastare tutto questo per far funzionare il tutto o devo anche impostare delle regole di firewall di tipo "INPUT" "OUTPUT" o "FORWARD"?
Purtroppo sto preparando la macchina e fino a domani non posso fare le prove ...
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Gio Mag 24, 2007 10:48 pm    Oggetto: Rispondi citando

No non ti server altro. Da quello che hai postato credo tu stia utilizzando la beta1 o la beta2 perché dalla beta3 ho rimosso il destination NAT automatico quando si usano i Virtual Server. Leggi il post http://www.zeroshell.net/forum/viewtopic.php?t=223

Ciao
Fulvio
Top
Profilo Invia messaggio privato
Sethi



Registrato: 24/05/07 21:07
Messaggi: 16

MessaggioInviato: Gio Mag 24, 2007 11:09 pm    Oggetto: Rispondi citando

Guarda non ricordo.. Ma ormai il pc è nel baule dell'auto quindi fino a domani non ti so dire Wink
Top
Profilo Invia messaggio privato
Sethi



Registrato: 24/05/07 21:07
Messaggi: 16

MessaggioInviato: Gio Mag 24, 2007 11:17 pm    Oggetto: Rispondi citando

Che stupido bastava guardare la iso che ho scaricato che era ancora su questo pc.. è la Beta4
Top
Profilo Invia messaggio privato
Sethi



Registrato: 24/05/07 21:07
Messaggi: 16

MessaggioInviato: Ven Mag 25, 2007 10:38 am    Oggetto: Rispondi citando

Uhm... macchina installata. In pubblica vedo l'interfaccia di configurazione web senza problemi... Però quando cerco da remoto di telnettare la porta 22000 (una di quelle che avevo configurato in pubblica) niente funziona... Cosa mi conviene fare per iniziare a debuggare?
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it