Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

[risolto] Problema accesso SSH (ma anche https)

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
mm



Registrato: 18/08/10 13:31
Messaggi: 9

MessaggioInviato: Lun Ago 30, 2010 4:46 pm    Oggetto: [risolto] Problema accesso SSH (ma anche https) Rispondi citando

Salve, gli scorsi giorni ho consegnato presso un cliente la mia prima installazione di ZeroShell, che avevo in precedenza minuziosamente messo a punto nel mio studio. Amministrazione da remoto compresa. E il problema sta proprio qui.

ZS è installato su un Alix la cui scheda di rete principale è collegata ad un modem/router Alice-Pirelli, sul quale ho creato i due Virtual Server, uno sulla porta interna 22 (per l'accesso SSH) e l'altro sulla 443 (per l'amministrazione via WEB); IP interno ovviamente quello di ZS, tipo TCP e porte esterne rispettivamente 112 e 111.

Mentre mi trovavo dal cliente ho provato al volo l'accesso SSH dal mio smartphone Android sul quale ho attiva una connessione 3G: l'accesso ha funzionato al primo colpo e sul piccolo display mi sono ritrovato la nota schermata principale di ZS.

In seguito ho provato dal mio studio dove ho una normale connessione ADSL; dalla mia linux box ho dato un
Codice:
ssh admin@1.2.3.4:112

ma la risposta è stata
Codice:
ssh: Could not resolve hostname 1.2.3.4:112: Name or service not known

Lanciando un ping la risposta è regolare: nessun pacchetto perso.

Qualche idea? Altre prove che posso fare?

P.S. Non funziona neppure l'amministrazione via web e temo che la causa del problema sia la stessa...

Grazie, Marco M.

Nota: 1.2.3.4 è ovviamente un indirizzo esemplificativo.


L'ultima modifica di mm il Lun Ago 30, 2010 11:57 pm, modificato 2 volte
Top
Profilo Invia messaggio privato
ufoonline



Registrato: 03/07/08 22:16
Messaggi: 261

MessaggioInviato: Lun Ago 30, 2010 8:11 pm    Oggetto: Rispondi citando

ti eri dimenticato di cambiare l'ip sull'altro quote, quindi ho provato a connettermi e risponde sia l'interfaccia web da una parte che ssh dall'altra...
hai risolto da te?
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Lun Ago 30, 2010 10:40 pm    Oggetto: Rispondi citando

La sintassi di ssh e'

ssh -p 112 1.2.3.4

quindi non usare i :

Ciao
Top
Profilo Invia messaggio privato
mm



Registrato: 18/08/10 13:31
Messaggi: 9

MessaggioInviato: Lun Ago 30, 2010 11:55 pm    Oggetto: Rispondi citando

Grazie ad entrambi: con le vostre note ed alcune altre prove sono riuscito a risolvere.

Accesso SSH (che non andava)
Era proprio colpa della sintassi e quella corretta è come indicata da Fulvio; anzi, per la precisione, volendo usare l'utente admin si deve scrivere:
Codice:
ssh -p 112 admin@1.2.3.4


Accesso WEB (che non andava)
Da Firefox è stato necessario fargli capire che l'utilizzo di una porta non standard per la navigazione web è una cosa voluta e da non bloccare; allo scopo bisogna richiamare il file di configurazione digitando l'URL speciale "about:config" ed aggiungere il parametro
Codice:
network.security.ports.banned.override

con valore 111 (nel mio caso). Così si può accedere al pannello di amministrazione web con l'URL https://1.2.3.4:111

Anche Chrome ed Epiphany - gli altri browser che utilizzo regolarmente - impediscono l'accesso per restrizioni sull'uso delle porte, ma non ho ancora trovato il modo di sbloccare.

Cordiali saluti, Marco M.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it