Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Boot da HD SATA

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
dodo



Registrato: 12/01/09 15:10
Messaggi: 6
Residenza: Udine, Italy

MessaggioInviato: Lun Gen 12, 2009 3:17 pm    Oggetto: Boot da HD SATA Rispondi citando

Ciao a tutti,
amministro la rete della residenza universitaria all'Erdisu di Udine. Avrei necessità di far avviare Zeroshell da Hard Disk.

Purtroppo ho un hard disk SATA e ho letto in diversi topic che l'avvio da dischi SATA non era possibile, solo da IDE, USB o CD. Tuttavia ho trovato, nella sezione "Annunci" del sito, che dalla beta10 dovrebbe essere supportato il boot da SATA.

Ho appena provato sul server che abbiamo qui. Ho eseguito tutta la procedura (prelevato l'immagine, scompattata con > su /dev/sda brutalmente), riavviato, tolto il CD e non va! (fa il probing dei device per 10 volte poi va in kernel panic).

Premetto che la procedura l'ho provata su una macchina virtuale che ho creato con il mio portatile, e l'immagine che ho scaricato è stata in grado di avviarsi.

Quindi il supporto per SATA esiste? C'è da modificare l'INITRD? Ho letto su un post che una soluzione potrebbe essere installare il toolkit per la compilazione del kernel + le sorgenti, ma vorrei evitare se possibile Smile

Grazie grazie
ciao
Tommaso.
_________________
---------

Tommaso D'Odorico
ERDISU Ente Regionale per il Diritto allo Studio
Udine.
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Lun Gen 12, 2009 7:57 pm    Oggetto: Rispondi citando

Il supporto per il boot da dischi SATA esiste a partire dalla 1.0.beta10. Purtroppo pero' non mi è possibile testare tutti i chipset e pertanto credo tu sia incappato in qualche incompatibilità. Puoi sempre fare il boot da pen disk USB e memorizzare invece il profilo su disco SATA.

Ciao
Fulvio
Top
Profilo Invia messaggio privato
dodo



Registrato: 12/01/09 15:10
Messaggi: 6
Residenza: Udine, Italy

MessaggioInviato: Mar Gen 13, 2009 8:47 am    Oggetto: Rispondi citando

Grazie per la pronta risposta,
ho immaginato che fossi incappato in qualche compatibiiltà,
nell'English Forum ho trovato un altro topic dove un utente sembra aver risolto un problema copiando un modulino dentro l'initrd... Ora provo
Grazie mille
Tommaso.
_________________
---------

Tommaso D'Odorico
ERDISU Ente Regionale per il Diritto allo Studio
Udine.
Top
Profilo Invia messaggio privato
dodo



Registrato: 12/01/09 15:10
Messaggi: 6
Residenza: Udine, Italy

MessaggioInviato: Gio Gen 15, 2009 8:41 am    Oggetto: Problema risolto! Rispondi citando

Ciao!
Sfogliando nel forum in inglese avevo trovato qualcuno che sembrava aver risolto questo problema di incompatibilità.

ORA L'HO RISOLTO ANCHE IO, infatti ho appena avviato il server da HD sata e funziona benissimo!

Semplicemente l'initrd.gz nella partizione piccola di boot non conteneva il modulo che permetteva al kernel di accedere agli HD Sata del mio Server (è un HP Proliant).
Infatti ho scompattato initrd.gz, montato il file e copiato all'interno della directory /lib/sata/chipsets (che si trova "all'interno" di initrd.gz) tutti i file in modules/2.6.25.9/kernel/drivers/ata (all'interno del CD-ROM).
Smontato initrd.gz, ri-gzippato e poi ho atteso il successivo stallo del server (per non sconnettere decine di utenti) che è avvenuto ieri sera. Stamattina appena arrivato in ufficio ho riavviato la macchina e funziona che è una meraviglia!

Quindi SUGGERIMENTO: magari si potrebbe aggiornare l'immaginina disponibile sul sito inserendo quei file in initrd.gz per massimizzare le compatibilità. Sempre che non crei problemi di sicurezza.

Non sapete quanto sono felice! Nell'ultimo mese c'erano stati un sacco di problemi, perchè l'armadio server è polveroso, il CD si impolverava per cui dopo un po' di giorni di uptime il server non leggeva più il CD, si impallava e tutti gli studenti della casa dello studente venivano a lamentarsi che non andava internet eccetera... E ora finalmente ho risolto! (In realtà non sarebbe nei miei compiti visto che sono un tirocinante, ma visto che i tirocini servono per imparare... )

Grazie Fulvio per l'ottimo lavoro, Zeroshell è una meraviglia:
semplice da usare, molte funzioni, sicuro, open-source... meglio di così!

Ciao
Tommaso.
_________________
---------

Tommaso D'Odorico
ERDISU Ente Regionale per il Diritto allo Studio
Udine.
Top
Profilo Invia messaggio privato
tgw



Registrato: 16/12/08 14:43
Messaggi: 2

MessaggioInviato: Ven Mar 20, 2009 11:26 am    Oggetto: Rispondi citando

Ciao,

chiedo scusa già in partenza per la domanda relativa a un problema che è gia stato risolto.. Ma anche leggendo la procedura implementata non riesco a capire cosa devo fare..

Devo installare Zeroshell su un pc che monta la scheda madre P5LD2-VM della Asus, il problema di fondo è che ho un hard disk Sata.

La macchina non fa il boot nemmeno dal live cd alchè ho collegato l hd sata ad un altro computer e installato l'immagine di zeroshell "ZeroShell-1.0.beta11-CompactFlash-IDE-USB-SATA-1GB.img" però anche in questo caso poi rimontando l hd sata ricevo lo stesso il messaggio di kernel panic .

Come faccio ad aggiungere questo modulo per fargli rilevare il disco sata ? Ho nuovamente collegato l hd sata ad un altra macchina e montato le sue 3 partizioni..
Ho provato scompattare il file initrd.gz preso da (sda2/isolinux) con "gzip -d" e poi con cpio -i < initrd.. Ma ricevo "cpio: Malformed number"..

Non so più cosa provare.. Vi ringrazio di cuore in anticipo!
Top
Profilo Invia messaggio privato
piupigei



Registrato: 13/02/09 08:34
Messaggi: 12

MessaggioInviato: Ven Mar 20, 2009 11:37 am    Oggetto: Re: Problema risolto! Rispondi citando

Ciao, non ho capito bene alcuni passaggi!! mi potreste spiegare bene questa procedura?
grazie mille!!

dodo ha scritto:
Ciao!
Sfogliando nel forum in inglese avevo trovato qualcuno che sembrava aver risolto questo problema di incompatibilità.

ORA L'HO RISOLTO ANCHE IO, infatti ho appena avviato il server da HD sata e funziona benissimo!

Semplicemente l'initrd.gz nella partizione piccola di boot non conteneva il modulo che permetteva al kernel di accedere agli HD Sata del mio Server (è un HP Proliant).
Infatti ho scompattato initrd.gz, montato il file e copiato all'interno della directory /lib/sata/chipsets (che si trova "all'interno" di initrd.gz) tutti i file in modules/2.6.25.9/kernel/drivers/ata (all'interno del CD-ROM).
Smontato initrd.gz, ri-gzippato e poi ho atteso il successivo stallo del server (per non sconnettere decine di utenti) che è avvenuto ieri sera. Stamattina appena arrivato in ufficio ho riavviato la macchina e funziona che è una meraviglia!

Quindi SUGGERIMENTO: magari si potrebbe aggiornare l'immaginina disponibile sul sito inserendo quei file in initrd.gz per massimizzare le compatibilità. Sempre che non crei problemi di sicurezza.

Non sapete quanto sono felice! Nell'ultimo mese c'erano stati un sacco di problemi, perchè l'armadio server è polveroso, il CD si impolverava per cui dopo un po' di giorni di uptime il server non leggeva più il CD, si impallava e tutti gli studenti della casa dello studente venivano a lamentarsi che non andava internet eccetera... E ora finalmente ho risolto! (In realtà non sarebbe nei miei compiti visto che sono un tirocinante, ma visto che i tirocini servono per imparare... )

Grazie Fulvio per l'ottimo lavoro, Zeroshell è una meraviglia:
semplice da usare, molte funzioni, sicuro, open-source... meglio di così!

Ciao
Tommaso.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it