Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

QoS comportamento anomale. Help

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
Garluk



Registrato: 02/11/09 16:22
Messaggi: 6

MessaggioInviato: Mar Nov 17, 2009 12:19 pm    Oggetto: QoS comportamento anomale. Help Rispondi citando

Ho una macchina con zeroshell beta12.
Ho il captive portal attivo e l'http proxy attivo con dansguardian.

Il sistema malgrado tutto sembra andare anche se ho notato un aumento vertiginoso delle connessioni quando ho attivato il proxy (roba che si sono quadruplicate...).

Volevo attivare il QoS per limitare al minimo (auspicabile eliminare) il p2p, lo streaming (youtube e simili e radio fm) e le chat.
E gestire meglio il traffico dando un'esperienza d'uso migliore della rete.

Ho attivato sulle due interfacce (lan e wan) il QoS e su queste ho aggiunto le classi definite in class manager attivandole nel contempo.
Ho definito le seguenti classi
- BULK (classe per navigazione tipo www, pop, ftp, imap)
- Default (classe per traffico non classificato)
- IM (instant messaging)
- P2P
- STREAM (traffico streaming come radio e video)
- VOIP

In classifier ho definito le seguenti regole
Codice:

 S I O                              Description                                                         Class  Log
 1 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto http MARK set 0x11              BULK   no 
 2 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto smtp MARK set 0x11              BULK   no 
 3 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto pop3 MARK set 0x11              BULK   no 
 4 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto imap MARK set 0x11              BULK   no 
 5 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto ftp MARK set 0x11               BULK   no 
 6 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto skypeout MARK set 0x12          VOIP   no 
 7 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto skypetoskype MARK set 0x12      VOIP   no 
 8 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto h323 MARK set 0x12              VOIP   no 
 9 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto sip MARK set 0x12               VOIP   no 
10 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto teamspeak MARK set 0x12         VOIP   no 
11 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto msn-filetransfer MARK set 0x10  IM     no 
12 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto msnmessenger MARK set 0x10      IM     no 
13 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto yahoo MARK set 0x10             IM     no 
14 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto gtalk MARK set 0x10             IM     no 
15 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto irc MARK set 0x10               IM     no 
16 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto jabber MARK set 0x10            IM     no 
17 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto aim MARK set 0x10               IM     no 
18 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto aimwebcontent MARK set 0x10     IM     no 
19 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto http-rtsp MARK set 0xf          STREAM no 
20 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto http-itunes MARK set 0xf        STREAM no 
21 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto httpaudio MARK set 0xf          STREAM no 
22 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto httpvideo MARK set 0xf          STREAM no 
23 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto live365 MARK set 0xf            STREAM no 
24 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto replaytv-ivs MARK set 0xf       STREAM no 
25 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto rtsp MARK set 0xf               STREAM no 
26 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto bittorrent MARK set 0xe         P2P    no 
27 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto directconnect MARK set 0xe      P2P    no 
28 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto edonkey MARK set 0xe            P2P    no 
29 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto fasttrack MARK set 0xe          P2P    no 
30 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto http-dap MARK set 0xe           P2P    no 
31 * * MARK all opt -- in * out * 0.0.0.0/0 -> 0.0.0.0/0 LAYER7 l7proto http-freshdownload MARK set 0xe P2P    no 


Tutto ci├▓ premesso il problema ├Ę questo ├Ę che se vado a leggere le statistiche vedo questo:
Codice:

Interface/Class Priority DSCP Maximum Guaranteed Traffic Sent (bytes) Rate
ETH00 -- -- 1000Mbit/s 1000Mbit/s 2129188474  73912bit
         BULK Medium    --     --   19303513      0bit
      DEFAULT Medium    --     -- 2103731224  73912bit
           IM   Low  1Mbit/s   --          0      0bit
          P2P   Low  1Kbit/s   --          0      0bit
       STREAM   Low  1Kbit/s   --          0      0bit
         VOIP   Low     --     --    6154601      0bit
             
ETH01 -- -- 100Mbit/s 100Mbit/s    240507236  14088bit
         BULK Medium    --     --    2544923      0bit
      DEFAULT Medium    --     --  234917463  14088bit
           IM   Low  1Mbit/s   --          0      0bit
          P2P   Low  1Kbit/s   --          0      0bit
       STREAM   Low  1Kbit/s   --          0      0bit
         VOIP   Low     --     --    3046289      0bit


Come mai classifica male il traffico?
Dove si sbaglia?
C'├Ę un bug o un'incompatibilit├á fra il mark dei vari servizi attivati?

Consigli?
Top
Profilo Invia messaggio privato
VITO



Registrato: 03/04/07 23:29
Messaggi: 352

MessaggioInviato: Mar Nov 17, 2009 5:37 pm    Oggetto: Rispondi citando

Prova a leggere le problematiche da me rilevate nel post
x fulvio oppure nelle segnalazioni bug fatte da me e dimmi se nella tua configurazione trovi riscontro in qualche mia configurazione.
Descrivo parecchie configurazioni dove sono presenti anomalie.
Ti consiglio di provare la tua attuale configurazione con la beta 11
con la patch di sicurezza installata (evitando di installare altro)che dovrebbe dare meno noie in presenza di un'installazione di Dansguardian.
Fammi sapere.(Nella sezione adeguata.)
"""Ti consiglio di spostare la tua domanda nella sezione apposita del forum di nuova creazione di fulvio altrimenti facciamo casini""""
Saluti Vito
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it