Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

PROBLEMA DI ROTTA VPN LAN-TO_LAN IPSEC

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
merlino63



Registrato: 10/12/09 11:55
Messaggi: 3

MessaggioInviato: Gio Dic 10, 2009 12:05 pm    Oggetto: PROBLEMA DI ROTTA VPN LAN-TO_LAN IPSEC Rispondi citando

Ciao a tutti,
sto' lavorando da non molto con Zeroshell e devo dire che la trovo davvero una bella soluzione. Ho riscontrato un problema e volevo verificare con voi se vi e' gia' capitato. In pratica ho collegato lo ZS con un Firewall CHECK POINT in modalita' IPSEC, seguendo le indicazioni che il buon atavachron aveva inserito nel forum e il collegamento VPN si attiva, da log si evidenzia che il Tunnel e' attivo e verificando sulla tabella di routing, l'indirizzo privato della sede remota e' correttamente gestito. Il problema che si pone e' che in realta' effettuando un ping o un tracert verso uno degli indirizzi della sede remota, ZS instrada verso la rete pubblica...... Embarassed
Vi e' mai successo?? dove sta' il problema??
Vi ringrazio per qualsiasi infomazione potrete darmi in merito
Grazie di tutto
Ciao
Top
Profilo Invia messaggio privato
merlino63



Registrato: 10/12/09 11:55
Messaggi: 3

MessaggioInviato: Gio Dic 10, 2009 4:09 pm    Oggetto: Re: PROBLEMA DI ROTTA VPN LAN-TO_LAN IPSEC Rispondi citando

merlino63 ha scritto:
Ciao a tutti,
sto' lavorando da non molto con Zeroshell e devo dire che la trovo davvero una bella soluzione. Ho riscontrato un problema e volevo verificare con voi se vi e' gia' capitato. In pratica ho collegato lo ZS con un Firewall CHECK POINT in modalita' IPSEC, seguendo le indicazioni che il buon atavachron aveva inserito nel forum e il collegamento VPN si attiva, da log si evidenzia che il Tunnel e' attivo e verificando sulla tabella di routing, l'indirizzo privato della sede remota e' correttamente gestito. Il problema che si pone e' che in realta' effettuando un ping o un tracert verso uno degli indirizzi della sede remota, ZS instrada verso la rete pubblica...... Embarassed
Vi e' mai successo?? dove sta' il problema??
Vi ringrazio per qualsiasi infomazione potrete darmi in merito
Grazie di tutto
Ciao


Ho trovato la solzione al problema. In pratica si rende necessario aggiungere nello #Startup Script sezione Nat e Virtual Server i seguenti comandi:
iptables -t nat -I PREROUTING 1 -s rete destinazione -d rete locale -j ACCEPT
iptables -t nat -I POSTROUTING 1 -s rete locale -d rete destinazione -j ACCEPT

Altra cosa sul file pskey.conf non utilizzare i : per separare indirizzo peer e shared key ma utilizzare spazio... Very Happy

Ciao
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it