Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Aiuto su un'installazione Captive Portal

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
MaLoX



Registrato: 07/04/10 11:22
Messaggi: 6

MessaggioInviato: Ven Lug 02, 2010 12:06 am    Oggetto: Aiuto su un'installazione Captive Portal Rispondi citando

Ciao a tutti ragazzi, vi spiego subito il problema.

Come hardware ho:

1 Router Tiscali
1 Access Point Planet
1 Computer ( Ubuntu 10 karmic koala )

Sul computer ho:

Un server Apache e Mysql con ip 192.168.1.2
Una macchina virtuale di ZeroShell con ip: 192.168.1.3

Il router tiscali ha l'ip 192.168.1.254 e non si puo cambiare
L'access point ha l'ip 192.168.1.1

Ho chiamato la tiscali ed ho fatto disattivare il dhcp.

Poi ho collegato il tutto nel seguente modo:

AP **************
*
ROUTER TISCALI
*
PC *****************

entrambi stanno dietro al router tiscali.

All'AP posso impostare ip subnet e gateway e stanno impostati nel seguente modo:

192.168.1.1
255.255.255.0
192.168.1.3

Il dhcp dell'AP č abilitato, e si possono impostare diversi parametri di rilascio, tra cui, che IP GATEWAY rilasciare.

Quindi l'ho configurato in questo modo:

Ip di rilascio: 192.168.1.10 - 192.168.1.200.
Gateway di rilascio: 192.168.1.3

Come parametri di ubuntu ho messo:

192.168.1.2
255.255.255.0
192.168.1.254
( ip del router di tiscali )

Mentre la macchina zeroshell č configurata in questo modo:

192.168.1.3
255.255.255.0
192.168.1.254
( ip del router di tiscali )

Sulla macchina ZeroShell ho disattivato il dhcp ed ho attivato il captive portal.

Fin qui tutto ok, č tutto in rete.

Se provo a collegarmi tramite wirless all'AP, mi rilascia come gateway: 192.168.1.3 ( Gateway di ZH ) e come ip 192.168.1.10 ( primo ip della serie del dhcp dell'AP )

Provo a digitare ad esempio: www.zeroshell.net, ma resta li fermo cercando di connettersi all'host all'infinito, senza che mi esca la schermata di captive portal.

Provo invece ad andare sull'ip 192.168.1.3 e mi compare la schermata di captive portal.

A questo punto penso che ci sia qualcosa di sbagliato nella mia configurazione di rete, ma non riesco a venirne a capo.

Sapete dirmi dove sbaglio?

Grazie anticipatamente.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it