Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

[Problema] Dansguardian su zeroshell non viene installato

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
liscazza



Registrato: 12/06/11 12:26
Messaggi: 9

MessaggioInviato: Dom Giu 12, 2011 1:52 pm    Oggetto: [Problema] Dansguardian su zeroshell non viene installato Rispondi citando

Ciao a tutti, spero che qualcuno possa aiutarmi, ho provato ad installare dansguardian da shell, la procedura la prima volta non andava a buon fine perche mancava A500 , dopo aver visto cosa era l'ho installato decomprimendolo dentro /Database e dando il comando ./install

stessa cosa ho fatto poi con AA00 ed è andato a buon fine con tanto di messaggino su dove posso trovare i file di configurazione ecc... ecc.., solo che non si è installato, infatti se vado in /etc non c'è la cartella dansguardian e ovviamente non compare nulla di nuovo nella pagina del http proxy.

Qualcuno potrebbe dirmi come mai? non credo sia un problema di permessi, lo eseguo in ssh dalla shell di root!

Aggiungo "ho appena visto che vanno di pari passo con le beta release" non c'è nessuna compatibilità tra le versioni? io ho ZS beta 14

Qualche soluzione?

Grazie in anticipo per le risposte
Top
Profilo Invia messaggio privato
liscazza



Registrato: 12/06/11 12:26
Messaggi: 9

MessaggioInviato: Dom Giu 12, 2011 3:14 pm    Oggetto: Rispondi citando

Ho risolto il probe a dell'installazione, ho seguito ciò che si diceva in questo tread http://www.zeroshell.net/forum/viewtopic.php?t=2472&postdays=0&postorder=asc&highlight=dansguardian+esterno&start=20

E ho fatto le stesse cose con BA13 --> BA14

Il problema è che adesso se abilito il proxy non passa più nulla, e non viene restituito nessun messaggio di dansguardian, e nemmeno nei log ve traccia!

Qualcuno può dirmi il modo più rapido per risolvere ?
A limite al momento adrebbe bene anche il modo corretto di disinstallare dansguardian.


Ciao, grazie
Top
Profilo Invia messaggio privato
fank



Registrato: 03/06/11 12:22
Messaggi: 48

MessaggioInviato: Mar Feb 14, 2012 5:03 pm    Oggetto: Rispondi citando

liscazza ha scritto:
Ho risolto il probe a dell'installazione, ho seguito ciò che si diceva in questo tread http://www.zeroshell.net/forum/viewtopic.php?t=2472&postdays=0&postorder=asc&highlight=dansguardian+esterno&start=20

E ho fatto le stesse cose con BA13 --> BA14

Il problema è che adesso se abilito il proxy non passa più nulla, e non viene restituito nessun messaggio di dansguardian, e nemmeno nei log ve traccia!

Qualcuno può dirmi il modo più rapido per risolvere ?
A limite al momento adrebbe bene anche il modo corretto di disinstallare dansguardian.


Ho reinstallato tutto almeno 3 volte e ho ricreato il profilo più di 8 volte, ricontrollato le ricorrenze di beta13, di b13 e di BA13 per passare a *16. Il pacchetto si installa correttamente, in HTTP proxy c'è il bottone per il log del content filtering ma non naviga affatto. Se disabilito http proxy funziona di nuovo. Insomma sono al tuo stesso punto. Tu hai trovato una soluzione?
Top
Profilo Invia messaggio privato
redfive



Registrato: 26/06/09 22:21
Messaggi: 772

MessaggioInviato: Mar Feb 14, 2012 7:44 pm    Oggetto: Rispondi citando

Ciao , hai provato ad editare il file
Codice:
/etc/dansguardian/dansguardian.conf
cambiando
Codice:
# the port that DansGuardian listens to.
filterport = 8080
con
Codice:
# the port that DansGuardian listens to.
filterport = 55559
?? a me sembra funzionare ...utilizzo la B16.
ciao
Top
Profilo Invia messaggio privato
fank



Registrato: 03/06/11 12:22
Messaggi: 48

MessaggioInviato: Mar Feb 14, 2012 10:15 pm    Oggetto: Rispondi citando

redfive ha scritto:
Ciao , hai provato ad editare il file
Codice:
/etc/dansguardian/dansguardian.conf
cambiando
Codice:
# the port that DansGuardian listens to.
filterport = 8080
con
Codice:
# the port that DansGuardian listens to.
filterport = 55559
?? a me sembra funzionare ...utilizzo la B16.
ciao


PERFETTO!
lanciando un netstat con
Codice:
netstat -anp --tcp | grep LISTEN

ho effettivamente visto che il dansguardian è in listening sulla 55559. Sinceramente non ho proprio pensato a controllare la porta, immaginavo che non fosse stata cambiata. Modifico il pacchetto mettendo nel dansguardian.conf la porta 55559 e lo posto a Fulvio.
Grazie!
Top
Profilo Invia messaggio privato
xvince



Registrato: 12/03/10 18:17
Messaggi: 43
Residenza: L'Aquila

MessaggioInviato: Lun Feb 20, 2012 12:37 pm    Oggetto: Rispondi citando

redfive ma non potevi uscirtene prima con questo suggerimento???
Dopo alcuni tentativi fatti appena uscita la beta16 mi ero rassegnato, mai pensato di dover cambiare la porta.
A questo punto vorrei capire come mai è cambiata la porta, visto che sulla 55559 c'è havp!!!

xvince
Top
Profilo Invia messaggio privato
marianocristallo



Registrato: 08/02/13 11:52
Messaggi: 2

MessaggioInviato: Ven Feb 08, 2013 11:58 am    Oggetto: Rispondi citando

io ho su dansguardian 55559 ....ma ho lostesso problema...qualcuno ha risolto???

grazie
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it