Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Cap. Portal-accesso libero dopo autenticazione primo utente

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
ciutino



Registrato: 09/10/13 09:14
Messaggi: 2

MessaggioInviato: Mer Ott 09, 2013 9:21 am    Oggetto: Cap. Portal-accesso libero dopo autenticazione primo utente Rispondi citando

Salve a tutti, sono nuovo del forum in quanto mi sono avvicinato a Zeroshell da poco tempo.
Ultimamente sto avendo dei problemi con il Captive Portal del sistema ZS Release 2.0 RC2 che ho messo in piedi.
Nonostante abbia smanettato abbastanza tra le varie funzioni non ne riesco a venire a capo, spero qualcuno abbia un idea a riguardo.

La configurazione prevede:

scheda interna ETH00 192.168.0.1
scheda esterna ETH01 192.168.1.200
default Router 192.168.1.1

Alla rete interna ho collegato un access point in modalità router.
In particolare si tratta di un access point ubiquiti in modalità SOHO ROUTER
con indirizzo WAN 192.168.0.254 NETMASK 255.255.255.0 GATEWAY+ROUTER 192.168.0.1
INTERFACCIA LAN 192.168.2.1 con DHCP 192.168.2.2 - 192.168.2.254 e NAT ABILITATO (ho verificato che se non lo abilito il captive portal non mi da accesso).
Nella scheda router del pannello di amministrazione ZS ho aggiunto l'apparato (STATIC ROUTE CONFIG) impostando i seguenti parametri:

DESTINATION 192.168.2.0 GATEWAY 192.168.0.254 NETMASK 255.255.255.0 METRIC 1

Il problema riscontrato è che non appena uno qualsiasi degli utenti ZS effettua l'accesso al captive portal, tutti gli altri utenti che si connettono dopo, navigano senza che gli venga chiesta alcuna credenziale.

Nel frattempo sul pannello di amministrazione del captive portal risulta connesso soltanto il primo utente, quello che fa accesso, e il suo indirizzo corrisponde al quello del router ovvero 192.168.0.254.

Dove sto sbagliando? Qualcuno riesce a darmi qualche delucidazione in merito?
Top
Profilo Invia messaggio privato
redfive



Registrato: 26/06/09 22:21
Messaggi: 774

MessaggioInviato: Mer Ott 09, 2013 11:29 am    Oggetto: Rispondi citando

Prova a togliere il nat dall'ubiquiti e in ZS>>CP , Client Identity , specifica solo l'ip address.
ciao
Top
Profilo Invia messaggio privato
ciutino



Registrato: 09/10/13 09:14
Messaggi: 2

MessaggioInviato: Mer Ott 09, 2013 2:20 pm    Oggetto: Rispondi citando

Ciao redfive,
il problema era proprio quello..
ti ringrazio tanto per la dritta..
A presto, grazie ancora..
Top
Profilo Invia messaggio privato
biotech



Registrato: 18/10/08 11:14
Messaggi: 34

MessaggioInviato: Mar Ott 22, 2013 6:19 pm    Oggetto: Rispondi citando

Se imposti l'Ubiquiti in modalità Router, ZS vede le richieste come provenienti tutte da uno stesso MAC, perciò poi tutti i client connessi si autenticano direttamente....

Io personalmente setto il NAT sull'interfaccia ZS dedicata al wi-fi e lo disabilito dall'apparato Ubiquiti.

Ciao
Top
Profilo Invia messaggio privato Invia e-mail
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it