Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

[URGENTE] Captive Portal ...

 
Nuovo argomento   Rispondi    Indice del forum -> Segnalazione BUG
Precedente :: Successivo  
Autore Messaggio
spaccabits



Registrato: 10/12/12 00:40
Messaggi: 8

MessaggioInviato: Mar Apr 22, 2014 2:30 am    Oggetto: [URGENTE] Captive Portal ... Rispondi citando

...mi sta facendo bestemmiare ... è (quasi) l'unica funzione che mi interessa veramente ...

ZS 3.0.0 con l'ultimo kernel (qualcosa.82, il precedente tendeva a piantarsi)
Configurazione con 3 schede, 2 ethernet e una wireless; la prima è dedicata per uscire in Internet, con IP dinamico dallo ISP, la seconda (ETH01) con IP x.y.w.1 maschera 255.255.255.0, la terza (WLAN00) con IP x.y.z.1 maschera come sopra; NAT sulla ETH00 (Internet); DHCP per ETH01 e WLAN00 con gateway i ripettivi indirizzi delle relative chede di rete e DNS quello dello ISP.

Il Captive (davvero molto cattivo Very Happy ) configurato su ETH01 non fa uscire in Internet Surprised , su WLAN00 si "naviga" che è una meraviglia Shocked ; configurato in "MULTI" non si va da nessuna parte; disabiliato il Captive funziona tutto ... anche mandando "down" la wireless non cambia nulla.
L'idea è quella di abilitarlo solo per chi si collega via ETH01, chi si collega su WLAN00 non dovrebbe passare dall'autenticazione.

Soluzioni?

EDIT
invertiti gli IP delle ETH01 e della WLAN00 funziona tutto!! Shocked Shocked Shocked ... o quasi, vedi sotto ...

2) EDIT (ancora sul cattivissimo "Captive")
Controllando i logs delle connessioni degli utenti ho notato qualche stranezza: intanto ho dovuto disabilitare il MAC address sulla "Client Identity" nella parte Gateway parameters, non serviva a nulla: mi prendeva un solo e sempre lo stesso MAC adress per tutti i client, quello dell'AP client - totalmente passivo - che, tramite un altro AP - con rete Wi-Fi aperta al solo AP client -, collega l'edificio in cui è posizionato ZS con un edificio a circa 30 metri Shocked , inoltre da qualche giorno dai logs sono sparite le indicazioni di quantità di traffico, tutte a 0, sono rimaste solamente le indicazioni dei tempi e dei costi (chi si collega deve contribuire, la connessione ad 1Mbs costa quasi 100€ al mese Exclamation )
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> Segnalazione BUG Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it