Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Modem 3G compatibili

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Mar Giu 17, 2014 10:58 am    Oggetto: Modem 3G compatibili Rispondi citando

Ciao

La zeroshell è una figata!!!
Ma il mio modem 3G huawei sta tirando le cuoie, quindi mano al portafoglio....

Devo prendere una chiavetta o modem UMTS Hspa che possa andare bene per il mio acer con dentro la zeroshell, ho a casa uno vecchio alcatel x020 va bene? Come potrei rendoerlo compatibile??

Al massimo compro 1 nuovo, stabile funzionanate e soprattutto che non scaldi da matti, quale prendere?

Grazie
Top
Profilo Invia messaggio privato
svenny



Registrato: 18/09/08 12:11
Messaggi: 245

MessaggioInviato: Gio Giu 19, 2014 7:25 pm    Oggetto: Rispondi citando

Io utilizzo da un po' di tempo la chiavetta UMTS Onda MDC655: l'unico problema è che al boot la chiavetta non fa il switch automaticamente e quindi devo lanciare il comando usb_switch con gli opportuni parametri al boot. Per il resto la chiavetta funziona bene. Tempo fa ho provato anche la Huawei E3131 che funzionava bene (non ricordo se ho dovuto lanciare il comando usb_switch al boot).

Si tratta di chiavette un po' datate, ma credo si trovino ancora in commercio per pochi Euro.

Ciao
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Gio Giu 19, 2014 8:42 pm    Oggetto: Rispondi citando

mi diresti perfavore come fare questo switch da boot?

e molto importante interfacciare l'alcatel alla zeroshell, credo di avere lo stesso problema.

grazie
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Gio Giu 19, 2014 9:00 pm    Oggetto: Rispondi citando

vedi... quando la connetto mi da questo errore..




da cosa puo dipendere?
Top
Profilo Invia messaggio privato
svenny



Registrato: 18/09/08 12:11
Messaggi: 245

MessaggioInviato: Gio Giu 26, 2014 12:29 am    Oggetto: Rispondi citando

Credo dipenda dal fatto che lo switch non avvenga correttamente. Io ho risolto il problema lanciando al boot il seguente comando:

Codice:

/usr/sbin/usb_modeswitch -v 0x1ee8 -p 0x004a -M 555342431234567800000000000010ff000000000000000000000000000000


Il comando che vedi sopra, funziona per il modello Onda MDC655, per far funzionare il tuo dispositivo devi controllare che sia presente in questa lista:

http://www.draisberghof.de/usb_modeswitch/device_reference.txt

ed inserire i valori corretti nel comando.

Ciao
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Gio Giu 26, 2014 4:12 pm    Oggetto: Rispondi citando

cè e un
Alcatel One Touch X020

quale eil comando esatto?
dal menu browser posso darle il comando?
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Gio Giu 26, 2014 4:16 pm    Oggetto: Rispondi citando

provo a mandare questo

/usr/sbin/usb_modeswitch -v 0x1c9e -p 0x1001 -M 55534243123456780000000000000606f50402527000000000000000000000

ma da dove lo mando?
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Gio Giu 26, 2014 4:29 pm    Oggetto: Rispondi citando

Looking for default devices ...
No devices in default mode found. Nothing to do. Bye.


[Pre Boot]: SUCCESS
Top
Profilo Invia messaggio privato
svenny



Registrato: 18/09/08 12:11
Messaggi: 245

MessaggioInviato: Ven Giu 27, 2014 12:42 am    Oggetto: Rispondi citando

Devi prima fare delle prove tramite la shell collegandoti con Putty se utilizzi Windows o tramite il comando SSH se utilizzi Linux (ci sono diverse guide per fare questo, puoi cercare anche nel forum). Una volta che sei nella shell, prova a staccare la chiavetta e riattaccarla dopo qualche secondo. Poi lanci il comando:

Codice:

lsusb


Dovresti vedere una riga (tra le altre) del tipo:

Codice:

Bus 001 Device 023: ID 0x1c9e:0x1001 Alcatel One Touch X020


Dove 0x1c9e e 0x1001 corrispondono all'ID vendor ed ID product del dispositivo prima dello switch. Se non vedi nulla del genere, significa che il sistema non lo riconosce. In questo caso questa guida non ti sara' di grande aiuto.

Se lo riconosce, lanci il comando che hai preparato:

Codice:

/usr/sbin/usb_modeswitch -v 0x1c9e -p 0x1001 -M 55534243123456780000000000000606f50402527000000000000000000000


Se il comando ha funzionato a dovere, rilanciando il comando lsusb dovresti vedere una riga del genere:

Codice:

Bus 001 Device 023: ID 0x1c9e:0xXXXX Alcatel One Touch X020


Dove 0xXXXX sara' l'ID product del dispositivo dopo lo switch.

Non so dirti di preciso quale sara' questo identificativo, ma dovra' essere diverso da 0x1001 (questo comportamento e' indicativo del fatto che il dispositivo ha effettuato correttamente lo switch). Il messaggio da te indicato viene notificato quando il dispositivo ha gia' effettuato lo switch e che quindi, in teoria, dovrebbe essere gia' pronto per la connessione.

Infine puoi vedere se sono stati creati i file per l'utilizzo del dispositivo tramite il seguente comando:

Codice:

ls /dev/ttyUSB*


Alcuni dispositivi forniscono il dispositivo ttyACM, quindi per testare l'esistenza del file in questo caso il comando e'

Codice:

ls /dev/ttyACM*


Se la risposta al comando e':

Codice:

/dev/ttyUSB0  /dev/ttyUSB1 # o /dev/ttyACM0  /dev/ttyACM1


Puoi procedere con la configurazione della connessione 3G.

Se invece ricevi:

Codice:

ls: /dev/ttyUSB*: No such file or directory


o

Codice:

ls: /dev/ttyACM*: No such file or directory


lo switch non e' avvenuto correttamente. Cio' potrebbe essere dovuto ad una incompatibilita' tra la chiavetta e il software a bordo di ZeroShell.

Se tutto e' andato per il verso giusto, caricando il comando per lo switch in PreBoot, dovresti avere la chiavetta automaticamente disponibile al boot.

Ciao
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Ven Giu 27, 2014 3:46 am    Oggetto: Rispondi citando

credo che stavolta devo buttar via l'alcatel, comunque grazie per le dritte, ti rimando ad un ultimo screen, che prova la mia rassegnazzione..



come vedi la omega non ce nell'elenco dei supportati, dico bene?
Top
Profilo Invia messaggio privato
svenny



Registrato: 18/09/08 12:11
Messaggi: 245

MessaggioInviato: Ven Giu 27, 2014 9:19 am    Oggetto: Rispondi citando

L'Omega WL-72B non lo vedo nell'elenco dei dispositivi supportati. Potresti provare tramite i seguenti comandi, anche se ho qualche dubbio che possa funzionare:

Codice:

modprobe option

/bin/echo "1c9e 6061" >/sys/bus/usb-serial/drivers/option1/new_id


Ciao
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Ven Giu 27, 2014 12:39 pm    Oggetto: Rispondi citando

perche se è un alcatel x020 viene fuori OMEGA?

non dovrebbe essere alcatel?
Top
Profilo Invia messaggio privato
Andante



Registrato: 28/10/13 19:27
Messaggi: 23

MessaggioInviato: Ven Giu 27, 2014 12:57 pm    Oggetto: Rispondi citando

FUNZIONA GRAZIE INFINITE....

mi spieghi cosa ho fatto con quel comando?

thx
Top
Profilo Invia messaggio privato
svenny



Registrato: 18/09/08 12:11
Messaggi: 245

MessaggioInviato: Ven Giu 27, 2014 1:26 pm    Oggetto: Rispondi citando

Bene, sono felice di esserti stato di aiuto!

Citazione:

perche se e' un alcatel x020 viene fuori OMEGA?


Alcuni dispositivi vengono commercializzati con nomi diversi da quelli attribuiti dal vero costruttore.

Citazione:

mi spieghi cosa ho fatto con quel comando?


Quel comando carica il driver option: alcune chiavette per effettuare lo switch hanno bisogno di questo driver.

Ciao
Top
Profilo Invia messaggio privato
at1839Paolo



Registrato: 23/12/15 13:07
Messaggi: 2

MessaggioInviato: Mer Dic 23, 2015 1:25 pm    Oggetto: Re: Modem 3G compatibili Rispondi citando

Andante ha scritto:
Ciao

La zeroshell è una figata!!!



Buongiorno a tutti.

Possiedo due modem 3g mini pci express.

Il primo è un vecchio sierra wireless mc8780, funziona con tutto e funziona anche con ZeroShell.

Il secondo è un Ericsson 2XGNJ, altrimenti conosciuto come Dell 5550. Questo mi da un sacco di rogne, però sono sicuro che funziona perchè si connette regolarmente se configurato tramite networkManager/nmcli. Ho provato su Debian sia con la cli che con l'interfaccia grafica.
Ma, anche su Debian, non ne vuole sapere di funzionare con wvdial.

Non sono mai riuscito a farlo andare con ZeroShell, le interfacce TTYACM* sono riconosciute ma mi da questo errore e ... nulla da fare ...

Qualche idea? Grazie in anticipo. PaoloC.


13:21:11 pppd 2.4.7 started by root, uid 0
13:21:13 Serial connection established.
13:21:13 Using interface ppp0
13:21:13 Connect: ppp0 <--> /dev/ttyACM0
13:21:13 LCP terminated by peer
13:21:13 Hangup (SIGHUP)
13:21:13 Modem hangup
13:21:13 Connection terminated.
13:21:14 Exit.
Top
Profilo Invia messaggio privato
at1839Paolo



Registrato: 23/12/15 13:07
Messaggi: 2

MessaggioInviato: Dom Dic 27, 2015 2:03 pm    Oggetto: Re: Modem 3G compatibili Rispondi citando

Aggiungo, forse non era del tutto ovvio, che il kernel riconosce perfettamente la periferica e che una prima fase della connessione sembra avvenire.

dmesg ...

[ 8.408930] cdc_acm 6-1:1.1: ttyACM0: USB ACM device
[ 8.410055] cdc_acm 6-1:1.3: ttyACM1: USB ACM device
[ 8.411875] cdc_acm 6-1:1.9: ttyACM2: USB ACM device
[ 8.414421] usbcore: registered new interface driver cdc_acm
[ 8.414430] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[ 8.414834] cdc_wdm 6-1:1.5: cdc-wdm0: USB WDM device
[ 8.415235] cdc_wdm 6-1:1.8: cdc-wdm1: USB WDM device
[ 8.415467] usbcore: registered new interface driver cdc_wdm
[ 8.417354] ACPI Warning: SystemIO range 0x0000000000000B00-0x0000000000000B07 conflicts with OpRegion 0x0000000000000B00-0x0000
000000000B0B (\SMB0) (20140926/utaddress-254)
[ 8.417379] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[ 8.421924] sp5100_tco: SP5100/SB800 TCO WatchDog Timer Driver v0.05
[ 8.422054] sp5100_tco: PCI Revision ID: 0x42
[ 8.422103] sp5100_tco: Using 0xfed80b00 for watchdog MMIO address
[ 8.422120] sp5100_tco: Last reboot was not triggered by watchdog.
[ 8.422239] sp5100_tco: initialized (0xf7d7cb00). heartbeat=60 sec (nowayout=0)
[ 8.431339] cdc_ncm 6-1:1.6: MAC-Address: 02:80:37:ec:02:00
[ 8.432097] cdc_ncm 6-1:1.6 wwan0: register 'cdc_ncm' at usb-0000:00:13.2-1, Mobile Broadband Network Device, 02:80:37:ec:02:00
[ 8.432164] usbcore: registered new interface driver cdc_ncm
[ 8.435076] usbcore: registered new interface driver cdc_mbim


ifconfig -a

wwan0 Link encap:Ethernet HWaddr 02:80:37:EC:02:00
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)


log section pppd

12:34:36 Using interface ppp0
12:34:36 Connect: ppp0 <--> /dev/ttyACM0
12:34:36 Warning - secret file /etc/ppp/pap-secrets has world and/or group access
12:34:36 LCP terminated by peer
12:34:36 Hangup (SIGHUP)
12:34:36 Modem hangup
12:34:36 Connection terminated.
12:34:37 Exit.
12:34:43 pppd 2.4.7 started by root, uid 0
12:34:46 Serial connection established.
12:34:46 Using interface ppp0
12:34:46 Connect: ppp0 <--> /dev/ttyACM0
12:34:46 Warning - secret file /etc/ppp/pap-secrets has world and/or group access
12:34:46 LCP terminated by peer
12:34:46 Hangup (SIGHUP)
12:34:46 Modem hangup
12:34:46 Connection terminated.
12:34:47 Exit.

log section chat

12:32:18 ^M
12:32:19 ATD*99#^M^M
12:32:19 CONNECT
12:32:19 -- got it
12:32:19 send ()
12:34:14 abort on (BUSY)
12:34:14 abort on (NO CARRIER)
12:34:14 abort on (ERROR)
12:34:14 report (CONNECT)
12:34:14 timeout set to 15 seconds
12:34:14 send (AT^M)
12:34:14 expect (OK)
12:34:14 ^M
12:34:14 *EMRDY: 1^M
12:34:14 AT^M^M
12:34:14 OK
12:34:14 -- got it
12:34:14 send (ATD*99***1#^M)
12:34:14 expect (CONNECT)
12:34:14 ^M
12:34:15 ATD*99***1#^M^M
12:34:15 CONNECT
12:34:15 -- got it
12:34:15 send ()
12:34:24 abort on (BUSY)
12:34:24 abort on (NO CARRIER)
12:34:24 abort on (ERROR)
12:34:24 report (CONNECT)
12:34:24 timeout set to 15 seconds
12:34:24 send (AT^M)
12:34:24 expect (OK)
12:34:24 ^M
12:34:24 *EMRDY: 1^M
12:34:24 AT^M^M
12:34:24 OK
12:34:24 -- got it
12:34:24 send (ATD*99***1#^M)

at1839Paolo ha scritto:



Buongiorno a tutti.

Possiedo due modem 3g mini pci express.

Il primo è un vecchio sierra wireless mc8780, funziona con tutto e funziona anche con ZeroShell.

Il secondo è un Ericsson 2XGNJ, altrimenti conosciuto come Dell 5550. Questo mi da un sacco di rogne, però sono sicuro che funziona perchè si connette regolarmente se configurato tramite networkManager/nmcli. Ho provato su Debian e su Ubuntu 14 sia con la cli che con l'interfaccia grafica.
Ma stranamente, anche su Debian, non ne vuole sapere di funzionare con wvdial.

Non sono mai riuscito a farlo andare con ZeroShell, le interfacce TTYACM* sono riconosciute ma mi da questo errore e ... nulla da fare ...

Qualche idea? Grazie in anticipo. PaoloC.


13:21:11 pppd 2.4.7 started by root, uid 0
13:21:13 Serial connection established.
13:21:13 Using interface ppp0
13:21:13 Connect: ppp0 <--> /dev/ttyACM0
13:21:13 LCP terminated by peer
13:21:13 Hangup (SIGHUP)
13:21:13 Modem hangup
13:21:13 Connection terminated.
13:21:14 Exit.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it