Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Problema configurazione virtual server

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
chicchik



Registrato: 14/02/16 23:06
Messaggi: 1

MessaggioInviato: Dom Feb 14, 2016 11:12 pm    Oggetto: Problema configurazione virtual server Rispondi citando

Ho una Alix 2d13 sulla quale ho installato Zeroshell 3.4.0.
Le 3 schede di rete sono così configurate:
ETH0: 192.168.8.251 e collegata alla rete locale
ETH1: 192.168.1.251 collegata a modem ADSL TpLink TD-8616 con indirizzo 192.168.1.1.
ETH2: al momento non collegata
WLAN00 (ho inserito anche una vecchia miniPCI smontata da un vecchio access point ma ancora funzionate): 192.168.10.1 che fa da access point

La connessione ADSL (ip dinamico) viene fatta tramite PPPoE per via del modem connesso sulla ETH1. Viene quindi creata un’ulteriore interfaccia di rete PPP0 sulla quale è attivo il NAT.
E’ attivo NAT anche sulla porta ETH1 per accedere alla console del modem in caso di problemi.
Sono abilitati due server DCHP: uno sulla subnet 192.168.8.0 per fornire un range di indirizzi dal 100 al 150 per fornire indirizzi alle macchine cablate che si connettono, e uno sulla subnet 192.168.10.0 per fornire indirizzi dal 2 al 20 per le macchine che si connettono in wifi (una paio di cellulari e un notebook).

Questa parte di configurazione funziona tutta: la connessione ADSL viene stabilita, le macchine con IP statico hanno impostato come gateway quello dello zeroshell (192.168.8.251), le macchine (cablate e wifi) che ricevono DHCP navigano.

Ma oltre alla classica configurazione casalinga, che avrei potuto ottenere con un modem/router da 50 euro, vorrei fare qualcosa di più.
Vorrei partire con l’implementazione di un server di posta casalingo. Fisicamente la macchina che fa da server è già configurata. Dispongo di un nome di dominio registrato con Dyndns (mionome.biz) sul quale è anche attivo il servizio di DNS. Ho configurato, lato dominio, un record di tipo A con l’hostname mail.mionome.biz ed al quale faccio puntare il Mail Exchangers (MX): è un passaggio per il momento superfluo ma che mi potrebbe servire se un giorno decidessi di riportare il server di posta altrove. Lato Zeroshell ho quindi configurato il DDNS con i parametri corretti, lo stato mi dice UPDATED ed anche dalla console di dyndns mi dice che punta al mio indirizzo IP attuale.
Il prossimo passaggio è quello di far dirottare la porta 25 in ingresso dall’esterno sull’indirizzo 192.168.8.35 che è l’indirizzo del mio server di posta. Ho verificato preventivamente che il mio ISP (NGI, ho una ADSL F5) non blocchi il traffico su tale porta, ed in ingresso non lo fa. Sono quindi andato nella sezione VIRTUAL SERVERS ed indicato che il traffico che ricevo sull’interfaccia ppp0 proveniente da qualsiasi indirizzo sui protocolli TCP ed UDP sulla porta 25 venga dirottato sul server remoto 192.168.8.35 sempre sulla porta 25. Fatto questo mi blocco: il traffico in ingresso non viene dirottato. Pensando sia qualche problema a livello di server di posta, rimuovo la regola appena creata e ne creo una per far transitare il traffico della porta 5900 sulla macchina 192.168.140 per controllare via VNC il mio PC fisso. Ma anche qui il traffico non viene dirottato. Sotto riporto quest’ultima configurazione dei Virtual Server
Chain PREROUTING (policy ACCEPT 1717 packets, 114K bytes)
pkts bytes target prot opt in out source destination
0 0 DNAT tcp -- ppp0 * 0.0.0.0/0 0.0.0.0/0 tcp dpt:5900 to:192.168.8.140:5900
0 0 DNAT udp -- ppp0 * 0.0.0.0/0 0.0.0.0/0 udp dpt:5900 to:192.168.8.140:5900

Chain POSTROUTING (policy ACCEPT 118 packets, 12546 bytes)
pkts bytes target prot opt in out source destination
128K 9210K SNATVS all -- * * 0.0.0.0/0 0.0.0.0/0
26742 1837K MASQUERADE all -- * ppp0 0.0.0.0/0 0.0.0.0/0
4 208 MASQUERADE all -- * ETH01 0.0.0.0/0 0.0.0.0/0

Chain SNATVS (1 references)
pkts bytes target prot opt in out source destination

Di sicuro manca qualcosa alla mia configurazione: penso a qualcosa a livello firewall anche se pensavo che configurando la cosa in virtual server facesse poi lui in automatico. Mi sono guardato un po’ in giro nel forum ma non sono riuscito a chiarirmi le idee. Qualcuno ha qualche dritta da fornirmi?
Anticipatamente grazie mille a tutti.
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it