Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

apache non si esegue

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
davide.cavaleri



Registrato: 15/06/16 08:40
Messaggi: 3

MessaggioInviato: Mer Giu 15, 2016 8:56 am    Oggetto: apache non si esegue Rispondi citando

buongiorno a tutti.
mi trovo di fronte ad un guasto anomalo, rilevato facendo troubleshooting a una macchina zeroshell 3.2.0 su alix che non presentava piu' la maschera di login.
le porte 80 e 443 non sono in ascolto e non c'e' alcun processo apache in esecuzione. tentato l'avvio manuale tramite script di avvio e anche da prompt, ma non parte. l'anomalia sta nel non generare alcun messaggio log di errore. anche lanciando l'eseguibile direttamente, torna a capo senza errori. solo printando l'exit code del processo si vede che esce con 1 (errore), ma senza messaggi. dopo lunghe ricerche ho visto casi simili in cui qualcuno suppone che la corruzione di qualche modulo di apache possa dare sintomi simili (non errori a file di configurazione o simili perche' quelli generano messaggio d'errore), ma ancora non ne vengo a capo.
domanda: supponendo che l'aggiornamento a 3.4.0 ripristini eventuali file danneggiati, e' possibile farlo in quache modo a riga di comando? (non avendo l'interfaccia web disponibile).

buona giornata

davide
Top
Profilo Invia messaggio privato
davide.cavaleri



Registrato: 15/06/16 08:40
Messaggi: 3

MessaggioInviato: Ven Giu 17, 2016 1:19 pm    Oggetto: follow-up Rispondi citando

I realized strange dates on files in partition /dev/sda2 (the one mounted as cdrom), where httpd executable resides. so dumped that partition and one from same version of zeroshell, and half files are corrupted. httpd was correct, hence being executed, but surely was corrupted some required file. now restored from a working /dev/sda2 image...
I wonder what could have corrupted like this a read-only partition.
I obviously done couple read write test on the compact flash and apparently no errors...
will see if it works, otherwise I'll change it anyway.

thanks

david
Top
Profilo Invia messaggio privato
davide.cavaleri



Registrato: 15/06/16 08:40
Messaggi: 3

MessaggioInviato: Ven Giu 17, 2016 1:21 pm    Oggetto: seguito Rispondi citando

mi sono reso conto che per abitudine nei forum, ho scritto in inglese.
riassumendo, la partizione /dev/sda2 del sistema incriminato era piena di file corrotti. essendo di sola lettura supponevo danni hardware alla compact flash, ma apparentemente no. ripristinato versione corretta di /dev/sda2, vediamo se ripresenta il problema, a quel punto la sostituisco.
il problema con apache era sicuramente dovuto alla corruzione di quache aggiuntivo file richiesto.

grazie

davide
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it