Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Boot lentissimo da compact flash

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
carlogrieco



Registrato: 17/01/08 22:17
Messaggi: 46

MessaggioInviato: Gio Gen 17, 2008 10:24 pm    Oggetto: Boot lentissimo da compact flash Rispondi citando

Salve a tutti. Sto provando Zeroshell su uma Soekris 5501, utilizzando una CF da 2 gb prima, e da 1 gb 133x poi. In entrambi i casi la macchina impiega oltre 30 minuti per completare il boot e cominciare a rispondere. Passato questo tempo, funziona perfettamente e risponde rapidamente. All'inizio avevo ovviamente pensato a scarse prestazioni della CF, ma dopo averla sostituita con una 133x escluderei cio'.
Esperienze del forum?
Grazie
Carlo
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Gio Gen 17, 2008 10:29 pm    Oggetto: Rispondi citando

Hai provato le opzioni del BIOS
set ConMute=Enabled
set ConSpeed=38400
del Soekris Net5501-70 come suggerito nel post
http://www.zeroshell.net/forum/viewtopic.php?t=586

Saluti
Fulvio
Top
Profilo Invia messaggio privato
carlogrieco



Registrato: 17/01/08 22:17
Messaggi: 46

MessaggioInviato: Gio Gen 17, 2008 10:35 pm    Oggetto: Rispondi citando

Ci provo, poi riferisco.

Grazie per la rapida risposta

Carlo
Top
Profilo Invia messaggio privato
carlogrieco



Registrato: 17/01/08 22:17
Messaggi: 46

MessaggioInviato: Gio Gen 17, 2008 11:36 pm    Oggetto: Rispondi citando

In effetti con la CF 133x il problema e' diverso. Collegandomi con la seriale vedo che il boot si interrompe perche' la CF viene vista come Ide secondaria (vedi http://www.zeroshell.net/forum/viewtopic.php?p=1051&sid=3db209aa5e0b50c586d1cbbd4a51e0d9)

Ci sono per caso stati sviluppi sul problema?
La cosa strana e' che con la CF "lenta" dopo 20 minuti Zeroshell parte, ma non riesco ad accedere alla console in seriale. Quasi quasi metto una Vga sul soekris...
Top
Profilo Invia messaggio privato
cicciopasticcio



Registrato: 03/12/07 11:42
Messaggi: 30

MessaggioInviato: Ven Gen 18, 2008 2:25 pm    Oggetto: Rispondi citando

Sembra che il problema sia di vecchia data, ma in sostanza si difendono (quelli di Soekris) dicendo che è la CF che dice di voler essere "slave" (una forma di sottomissione volontaria Wink ) e il BIOS acconsente.
Qui ne parlavano:
http://lists.soekris.com/pipermail/soekris-tech/2007-October/013226.html
Io sto utilizzando una SanDisk UltraII da 2GB, spero di non fare pubblicità, vah che sia solo un "supported hardware list". Me la vede infatti come disco primario.
_________________
Marco Pamio - University of Udine - Italy
dunque "zero shell" .... humm, niente conchiglie da queste parti!
Top
Profilo Invia messaggio privato
cicciopasticcio



Registrato: 03/12/07 11:42
Messaggi: 30

MessaggioInviato: Ven Gen 18, 2008 2:37 pm    Oggetto: Rispondi citando

Prova da BIOS a dargli:
Codice:
set FLASH=Primary
Forse così va.
Dovrebbe darti infatti:
Codice:
comBIOS ver. 1.32i 20071005  Copyright (C) 2000-2007 Soekris Engineering.

net5501

0512 Mbyte Memory                        CPU Geode LX 500 Mhz

Pri Mas  SanDisk SDCFH-2048              LBA Xlt 992-64-63  2001 Mbyte
Notare il Pri Mas prima del nome della CF.
Io infatti ho provato a fare il contrario e il risultato è stato che con la seguente configurazione NON mi ha fatto il boot (giustamente):
Codice:
comBIOS ver. 1.32i 20071005  Copyright (C) 2000-2007 Soekris Engineering.

net5501

0512 Mbyte Memory                        CPU Geode LX 500 Mhz

Pri Sla SanDisk SDCFH-2048              LBA Xlt 992-64-63  2001 Mbyte
In definitiva dovrai ottenere:
Codice:
> show

ConSpeed = 38400
ConLock = Enabled
ConMute = Enabled
BIOSentry = Enabled
PCIROMS = Enabled
PXEBoot = Disabled
FLASH = Primary
BootDelay = 5
FastBoot = Disabled
BootPartition = Disabled
BootDrive = 80 81 F0 FF
ShowPCI = Enabled
Reset = Hard

>

e a questo punto propongo di spostare questa discussione nell'apposito spazio sui dispositivi embedded . Wink
_________________
Marco Pamio - University of Udine - Italy
dunque "zero shell" .... humm, niente conchiglie da queste parti!
Top
Profilo Invia messaggio privato
carlogrieco



Registrato: 17/01/08 22:17
Messaggi: 46

MessaggioInviato: Ven Gen 18, 2008 5:28 pm    Oggetto: Rispondi citando

In effetti la mia prima CF, quella che ho sostituito perche' lenta, e' una Sandisk. Appare quindi credibile quanto sostenuto da Soekris nella discussione da te citata, anche se non immagino la strana ragione che porti un Bios ad "assecondare" una simile richiesta.
Questa sera provero' a settarla da Bios come master.
Top
Profilo Invia messaggio privato
carlogrieco



Registrato: 17/01/08 22:17
Messaggi: 46

MessaggioInviato: Sab Gen 19, 2008 10:09 pm    Oggetto: Rispondi citando

CONCLUSIONE:

1 - La CF Lexar 133x viene rilevata sempre come Slave, anche con Set FLASH = primary.

2 - La CF Sandisk viene automaticamente rilevata come Master.

TEMPI DI AVVIO

La Sandisk (2 gb, velocita' non dichiarata) all'inizio del mio test impiegava almeno 20 minuti per completare il boot. Ho cambiato i parametri del Bios come suggerito da Cicciopasticcio, e adesso in 130 secondi Zeroshell e' operativo. Non mi e' chiaro l'effetto del cambio parametri del Bios, perche' dopo averli ripristinati ai valori originali i tempi di avvio sono rimasti buoni.

Grazie a entrambi per la collaborazione
Carlo
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it