Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Problema CP con due VLAN

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
copanto



Registrato: 24/04/17 16:03
Messaggi: 3

MessaggioInviato: Lun Apr 24, 2017 5:53 pm    Oggetto: Problema CP con due VLAN Rispondi citando

Salve. Prima di tutto grazie agli sviluppatori per il lavoro.
Utilizzo zero shell per gestire gli accessi in una scuola, trovo problemi con il captive portal quando si parla di VLAN.
In particolare su una VLAN (nel mio caso 1) ho i PC e su un'altra VLAN (ad esempio 2) ho un PC con zeroshell-zerotruth.

Premetto che con tutto su una VLAN ho il CP attivo con MAC address e IP autentication e tutto funziona OK (provato e verificato).

Se non attivo il CP (lasciamo stare tutta la configurazione OS6450, con VLAN routing e static route impostate) i pc su VLAN1 navigano senza problemi con zeroshell e router su VLAN 2.

Se attivo il CP (metto ovviamente autenticazione IP Only) ho questo comportamento strano: I pc che al momento dell'attivazione erano già in funzione e navigavano ricevono la richiesta di autenticarsi, ma i PC che non erano in funzione una volta accesi non ricevono nessuna pop-up di autenticazione e si ha solo il messaggio del browser di mancanza internet.

Perchè? Cosa posso controllare per risolvere il problema? Grazie mille.
Top
Profilo Invia messaggio privato
copanto



Registrato: 24/04/17 16:03
Messaggi: 3

MessaggioInviato: Ven Apr 28, 2017 12:54 pm    Oggetto: Aggiornamento Rispondi citando

La situazione è al momento questa:

Senza captive portal abilitato riesco far navigare i pc su VLAN2 e Cellulari e Tab.

Attivo il captive portal, i pc, i tablet e i cellulari android non ricevono la richesta di autenticarsi e rimangono con la pagina che non da connessione. Ma ho provato con un lumia 950 e un lumia 630, tutti e due windows phone e il portale funziona (cioè richiede l'autenticazione e una volta autenticati gli users navigano) !!!!!! Perchè? Credetemi ci sto perdendo la testa Mad Mad .
Nel log del captive portal vedo:
12:11:53 AS: Success: Captive Portal Authentication Server started
12:11:54 GW: Success: Captive Portal Gateway started (0 clients connected)
12:42:36 AS: Success: Captive Portal Authentication Server started
12:42:36 GW: Success: Captive Portal Gateway started (0 clients connected)
12:43:47 AS: Success: Captive Portal Authentication Server started
12:43:48 GW: Success: Captive Portal Gateway started (0 clients connected)
12:44:33 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: yes). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
12:44:56 AS: trying Radius authentication (PAP) for admin@example.com (Client: 192.168.2.147)
12:44:56 AS: Success: user admin@example.com (Client: 192.168.2.147) successfully authenticated (Username,Password)
12:44:57 GW: Success: user admin@example.com (IP: 192.168.2.147 MAC: ) connected
12:47:36 AS: Success: Captive Portal Authentication Server started
12:47:37 GW: Success: Captive Portal Gateway started (1 clients connected)
12:50:06 GW: warning: authenticator expired for admin@example.com (Client: 192.168.2.147)
12:50:07 GW: Success: user admin@example.com (IP: 192.168.2.147 MAC: ) disconnected
13:00:45 GW: Captive Portal Gateway is disabled
13:03:06 AS: Success: Captive Portal Authentication Server started
13:03:07 GW: Success: Captive Portal Gateway started (0 clients connected)
13:03:19 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: yes). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
13:03:50 message repeated 10 times
13:03:59 message repeated 3 times
13:04:02 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: yes). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
13:04:17 message repeated 4 times
13:06:27 AS: http session (Client: 192.168.2.119) captured for authentication (Popup: no). Browser: Mozilla/5.0 (Windows Phone 10.0; Android 6.0.1; Microsoft; Lumia 950) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Mobile Safari/537.36 Edge/14.14393
13:07:03 AS: trying Radius authentication (PAP) for admin@example.com (Client: 192.168.2.119)
13:07:03 AS: Success: user admin@example.com (Client: 192.168.2.119) successfully authenticated (Username,Password)
13:07:03 GW: Success: user admin@example.com (IP: 192.168.2.119 MAC: ) connected
13:13:23 GW: Captive Portal Gateway is disabled
13:14:07 AS: Success: Captive Portal Authentication Server started
13:14:08 GW: Success: Captive Portal Gateway started (1 clients connected)
13:14:12 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: no). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
13:14:44 message repeated 10 times
13:14:56 message repeated 4 times
13:15:01 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: no). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
13:15:07 message repeated 2 times
13:17:20 GW: Success: user admin@example.com (IP: 192.168.2.119 MAC: ) disconnected
13:17:24 AS: http session (Client: 192.168.2.119) captured for authentication (Popup: no). Browser: Mozilla/5.0 (Windows Phone 10.0; Android 6.0.1; Microsoft; Lumia 950) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Mobile Safari/537.36 Edge/14.14393
13:19:00 AS: http session (Client: 192.168.2.67) captured for authentication (Popup: no). Browser: Dalvik/2.1.0 (Linux; U; Android 6.0.1; SM-J710F Build/MMB29K) [FBAN/Orca-Android;FBAV/111.0.0.15.46;FBPN/com.facebook.orca;FBLC/it_IT;FBBV/53771448;FBCR/I WIND;FBMF/samsung;FBBD/samsung;FBDV/SM-J710F;FBSV/6.0.1;FBCA/armeabi-v7a:armeabi;FBDM/{density=2.0,width=720,height=1280};FB_FW/1;]
13:19:54 AS: trying Radius authentication (PAP) for admin@example.com (Client: 192.168.2.119)
13:19:54 AS: Success: user admin@example.com (Client: 192.168.2.119) successfully authenticated (Username,Password)
13:19:54 GW: Success: user admin@example.com (IP: 192.168.2.119 MAC: ) connected
13:20:42 AS: http session (Client: 192.168.2.247) captured for authentication (Popup: no). Browser: Mozilla/5.0 (Linux; Android 5.0; SM-G900F Build/LRX21T) AppleWebKit/537.36 (KHTML, like Gecko) Version/4.0 Chrome/37.0.0.0 Mobile Safari/537.36 [FB_IAB/FB4A;FBAV/115.0.0.20.72;]
13:20:58 GW: Success: user admin@example.com (IP: 192.168.2.119 MAC: ) disconnected
13:21:46 AS: http session (Client: 192.168.2.67) captured for authentication (Popup: no). Browser: Dalvik/2.1.0 (Linux; U; Android 6.0.1; SM-J710F Build/MMB29K) [FBAN/Orca-Android;FBAV/111.0.0.15.46;FBPN/com.facebook.orca;FBLC/it_IT;FBBV/53771448;FBCR/I WIND;FBMF/samsung;FBBD/samsung;FBDV/SM-J710F;FBSV/6.0.1;FBCA/armeabi-v7a:armeabi;FBDM/{density=2.0,width=720,height=1280};FB_FW/1;]
13:23:22 AS: http session (Client: 192.168.2.67) captured for authentication (Popup: no). Browser: Dalvik/2.1.0 (Linux; U; Android 6.0.1; SM-J710F Build/MMB29K) [FBAN/Orca-Android;FBAV/111.0.0.15.46;FBPN/com.facebook.orca;FBLC/it_IT;FBBV/53771448;FBCR/I WIND;FBMF/samsung;FBBD/samsung;FBDV/SM-J710F;FBSV/6.0.1;FBCA/armeabi-v7a:armeabi;FBDM/{density=2.0,width=720,height=1280};FB_FW/1;]
13:23:34 AS: http session (Client: 192.168.2.119) captured for authentication (Popup: no). Browser: Mozilla/5.0 (Windows Phone 10.0; Android 6.0.1; Microsoft; Lumia 950) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Mobile Safari/537.36 Edge/14.14393
13:23:53 GW: Captive Portal Gateway is disabled
13:32:04 AS: Success: Captive Portal Authentication Server started
13:32:05 GW: Success: Captive Portal Gateway started (0 clients connected)
13:32:12 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: yes). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
13:32:43 message repeated 4 times
13:32:43 AS: http session (Client: 192.168.2.119) captured for authentication (Popup: no). Browser: Mozilla/5.0 (Windows Phone 10.0; Android 6.0.1; Microsoft; Lumia 950) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Mobile Safari/537.36 Edge/14.14393
13:32:46 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: yes). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
13:32:49 AS: http session (Client: 192.168.2.147) captured for authentication (Popup: yes). Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
13:33:02 AS: trying Radius authentication (PAP) for admin@example.com (Client: 192.168.2.119)
13:33:02 AS: Success: user admin@example.com (Client: 192.168.2.119) successfully authenticated (Username,Password)
13:33:02 GW: Success: user admin@example.com (IP: 192.168.2.119 MAC: ) connected
13:35:26 AS: https session (Client: 192.168.2.66) captured for authentication (Popup: no). Browser: Mozilla/5.0 (Mobile; Windows Phone 8.1; Android 4.0; ARM; Trident/7.0; Touch; rv:11.0; IEMobile/11.0; NOKIA; Lumia 630; Vodafone) like iPhone OS 7_0_3 Mac OS X AppleWebKit/537 (KHTML, like Gecko) Mobile Safari/537
13:36:09 AS: trying Radius authentication (PAP) for admin@example.com (Client: 192.168.2.66)
13:36:09 AS: Success: user admin@example.com (Client: 192.168.2.66) successfully authenticated (Username,Password)
13:36:09 GW: Success: user admin@example.com (IP: 192.168.2.66 MAC: ) connected
13:38:49 GW: Success: user admin@example.com (IP: 192.168.2.66 MAC: ) disconnected
13:38:53 GW: Success: user admin@example.com (IP: 192.168.2.119 MAC: ) disconnected
13:41:28 GW: Captive Portal Gateway is disabled
Top
Profilo Invia messaggio privato
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it