Indice del forum www.zeroshell.net
Distribuzione Linux ZeroShell
 
 FAQFAQ   CercaCerca  GruppiGruppi   RegistratiRegistrati 
 ProfiloProfilo  Log inLog in   Messaggi privatiMessaggi privati 

Zeroshell non bootta nemmeno da CD

 
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell
Precedente :: Successivo  
Autore Messaggio
cisif



Registrato: 17/05/08 15:32
Messaggi: 20

MessaggioInviato: Sab Mag 17, 2008 3:36 pm    Oggetto: Zeroshell non bootta nemmeno da CD Rispondi citando

Salve a tutti: ho uno zeroshell in modalità bridge captive-portal installato su HD che funziona regolarmente per l'aula degli studenti del Centro di calcolo (50 PC) versione 1.0b7.
Sono voluto passare ad un PC più recente per allargare il bacino di utenza (docenti e non) ma non riesco nemmeno a partire con il boot da CD in quanto mi dà il seguente messaggio:

PCI: Not using MMCONFIG
Probe [hde]CDROM for mounting... Fail
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,2)

Il PC è così composto:
MB ASUS P5K ACPI
CPU Intel Core2 Quad 2.5MHz
4Gb RAM
CDROM EIDE
HD SATA

è già capitato a qualcuno e/o sapete indicarmi come risolvere?
Grazie in anticipo
_________________
Andrea Sbrana
Top
Profilo Invia messaggio privato Invia e-mail
giuliano



Registrato: 06/12/06 08:26
Messaggi: 73

MessaggioInviato: Dom Mag 18, 2008 12:30 pm    Oggetto: Rispondi citando

a occhio hai un cdrom sata )o un controller ide non supportato?) ... io ho risolto con la versione usb finchè non ci sarà un versione che supporta il boot da sata

giuliano
Top
Profilo Invia messaggio privato
cisif



Registrato: 17/05/08 15:32
Messaggi: 20

MessaggioInviato: Dom Mag 18, 2008 9:34 pm    Oggetto: Re: Rispondi citando

Purtroppo mi sa che non sia supportato l'IDE, dato che il CDROM è IDE.
In più, il bios non mi consente l'avvio da USB....... Crying or Very sad
Tutto ciò mi sembra paradossale: sul pc di 5 anni fa ha funzionato tutto al primo tentativo, mentre con quello nuovo e l'ultima release di ZS non ce la fa neanche a partire. Mi preoccupo per il fatto che, continuando ad utilizzare il vecchio PC, un giorno si guasterà e se non posso sostituirlo con uno più recente......
Peccato perchè il prodotto funziona veramente bene e si nota che chi l'ha realizzato lo sta curando sotto ogni punto di vista.
Grazie per l'aiuto

Andrea
_________________
Andrea Sbrana
Top
Profilo Invia messaggio privato Invia e-mail
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Lun Mag 19, 2008 8:55 pm    Oggetto: Rispondi citando

Ciao Andrea,
sei sicuro che sulla scheda madre non ci siano altri connettori IDE su cui installare il CDROM. Mi sembra strano che il Kernel abbia rilevato l'unità come hde. Ci deve essere qualcos'altro che viene riconosciuto come hda, hdb,hdc,hdd. A volte oltre al controller IDE normale ne viene affiancato uno RAID.
Poi strano che una motherboard di ultima generazione non consenta il boot da USB.

Saluti
Fulvio
Top
Profilo Invia messaggio privato
fulvio
Site Admin


Registrato: 01/11/06 17:45
Messaggi: 1558

MessaggioInviato: Lun Mag 19, 2008 8:58 pm    Oggetto: Rispondi citando

Verifica bene il boot USB, perché se non ricordo male io su una P5K sono riuscito a bootstrappare.

Saluti
Fulvio
Top
Profilo Invia messaggio privato
cisif



Registrato: 17/05/08 15:32
Messaggi: 20

MessaggioInviato: Mar Mag 20, 2008 7:41 am    Oggetto: Rispondi citando

Buogiorno Fulvio. Ieri ho cambiato SK madre ed ho preso un'Intel, ma tutto come prima.
In realtà il CD si avvia, poi dà il kernel panic quando va a testare le periferiche.
Ho installato Fedora e Ubuntu e mi sono accorto che il problema è semplicemente che non vede l'HD SATA.
Qui però mi fermo: probabilmente il passaggio successivo dovrebbe essere:
individuare il modulo di dialogo con l'HD
inserirlo nel CD di avvio ZeroShell
far ripartire il tutto
ma purtroppo non ne sono capace perchè non sono nato come sistemista...
Comunque ci proverò e vi farò sapere, anche perchè penso che tra non molto in tanti avranno lo stesso problema con i controller SATA che vanno a sostituire gli IDE.

Ciao

Andrea
_________________
Andrea Sbrana
Top
Profilo Invia messaggio privato Invia e-mail
cisif



Registrato: 17/05/08 15:32
Messaggi: 20

MessaggioInviato: Ven Mag 23, 2008 12:01 pm    Oggetto: Rispondi citando

Ho risolto tutto: per chiarezza posto i risultati delle prove.
Nel mio caso, ciò che impediva l'installazione era un conflitto su un indirizzo del bus PCI con la scheda video PCI-Express. Ho sostituito la MB con una con scheda video integrata ed il CDROM è partito.
Successivamente ho scoperto che il sistema boota solo da Primary Master IDE e così, avendo solo un canale IDE, ho tolto il CDROM e ho inserito l'HD. L'eventuale boot da CD lo faccio con CDROM ext via USB.
Un pò laborioso ma adesso funziona.

Buon lavoro a tutti

Andrea
_________________
Andrea Sbrana
Top
Profilo Invia messaggio privato Invia e-mail
Mostra prima i messaggi di:   
Nuovo argomento   Rispondi    Indice del forum -> ZeroShell Tutti i fusi orari sono GMT + 1 ora
Pagina 1 di 1

 
Vai a:  
Non puoi inserire nuovi argomenti
Non puoi rispondere a nessun argomento
Non puoi modificare i tuoi messaggi
Non puoi cancellare i tuoi messaggi
Non puoi votare nei sondaggi


Powered by phpBB © 2001, 2005 phpBB Group
phpbb.it